Support » Fixing WordPress » Featured Image – Cropped to 500×375 – Make it stop!

  • Resolved demon11c

    (@demon11c)


    This is driving me crazy, mainly because I fixed it before and now it’s back again to haunt me.

    Im not sure if this is specifically related to the theme Im using or general WordPress. I am using the Gallery theme.

    Basically, I insert an image into a new post and use it as a “featured image” so that it comes up as a thumbnail link on the front page.
    This works, except when I click on the link, the image in the post page has been cropped to 500×375.
    All my images are a perfect square so I need 500×500, but for the life of me I cannot find the option or file where I can change this.

    Can anyone help before I pull the rest of my hair out?
    Im sure it’s a simple answer.

    TIA

Viewing 9 replies - 1 through 9 (of 9 total)
  • It must have something to do with “Path to Full-Size Image (500×375)” under Gallery Post Settings on the New Post page, but I cant find out where to change this setting.

    esmi

    (@esmi)

    Forum Moderator

    Try looking in Settings -> Media.

    Thanks. Yes, I did.

    Thumbnail size = 150×150
    Medium size = 500×500
    Large size = 1400×1400

    But this doesnt seem to have any effect on the problem Im having.

    esmi

    (@esmi)

    Forum Moderator

    Is “Crop to exact size” checked? If not and you need square images, check it. Then install and run:
    http://wordpress.org/extend/plugins/regenerate-thumbnails/

    Yes, that box is checked. But actually it’s not the thumbnail that is the problem. It’s the actual post page that shows the large size image at 500×375 (I want 500×500).

    esmi

    (@esmi)

    Forum Moderator

    It could be your theme’s CSS.

    I found this in /wp-includes/js/crop:

    .imgCrop_wrap {
    	/* width: 500px;   @done_in_js */
    	/* height: 375px;  @done_in_js */
    	position: relative;
    	cursor: crosshair;
    }

    but it’s commented out and “cropper.js” does not contain “375” when I search for it. Not sure what else “@done_in_js” refers to…

    esmi

    (@esmi)

    Forum Moderator

    Please do not try changing any WordPress core files. This could be your theme’s CSS. Have you tried switching to the Twenty Eleven theme to rule out any theme-specific problems?

    Good call. The image is full size and un-cropped when I use Twenty Eleven.

    Found it in /wp-content/themes/gallery/functions.php. I replaced 500×375 with 500×500 in a couple of spots in that file and it’s fixed.

    Thanks for your help and quick replies.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Featured Image – Cropped to 500×375 – Make it stop!’ is closed to new replies.