WordPress.org

Forums

  1. baldgoat
    Member
    Posted 2 years ago #

    Using WP 3.5.1
    WooCommerce 2.0.5
    Smart Manager Lite 3.1.2

    When in the post edit screen, when I click the 'Set Featured Image' link I get the popup. The first thumb in the pop-up is blank - viewing the HTML in Chrome inspector reveals that there is no image tag for the thumb.

    While in the pop-up if I select the desired thumbnail and click the 'Set featured image' button, the pop-up goes away, but the featured image does not get set.

    If I deactivate 'Smart Manager Lite', I have no issues setting the featured image.

    http://wordpress.org/extend/plugins/smart-manager-for-wp-e-commerce/

  2. Ratnakar
    Member
    Plugin Author

    Posted 2 years ago #

    Please follow these steps to fix this issue:

    1. Go to file 'smart-manager.php' located at 'wp-content/plugins/smart-manager-for-wp-e-commerce'
    2. Go to line number 105 OR look for this code:
      // Including Scripts for using the wordpress new media manager
      if (version_compare ( $wp_version, '3.5', '>=' )) {
          define ( 'IS_WP35', true);
          wp_enqueue_media();
          wp_enqueue_script( 'custom-header' );
      }
    3. Replace it with following code:
      // Including Scripts for using the wordpress new media manager
      if (version_compare ( $wp_version, '3.5', '>=' )) {
          define ( 'IS_WP35', true);
          if ( isset( $_GET['page'] ) && ( $_GET['page'] == "smart-manager-woo" || $_GET['page'] == "smart-manager-wpsc" ) ) {
              wp_enqueue_media();
              wp_enqueue_script( 'custom-header' );
          }
      }
    4. Save the file. That's it!

    Now check whether the issue is resolved or not?

    We'll release a version of Smart Manager including this fix. Thank you for reporting.

    If still you are facing any issues with Smart Manager, please open a ticket from Store Apps Support

  3. Michael Kuhlmann
    Member
    Posted 2 years ago #

    Made the above edit and am still running into the same issue as baldgoat. I did purchase the plugin, though, so I'm anxiously awaiting the next release.

  4. Ratnakar
    Member
    Plugin Author

    Posted 2 years ago #

    Check it again after deactivating & re-activating the plugin.

    If still you are facing the issue, can you please take screenshots of errors in developer tool of chrome browser & send it as attachment on 'support@storeapps.org'

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Smart Manager for e-Commerce - WooCommerce and WPeC extension
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic