Support » Plugin: WebP Converter for Media » Feature suggestion: don’t install .htaccess when NGINX is used

  • Resolved pekkakortelainen

    (@pekkakortelainen)


    Hello!

    I’d like to suggest a feature. Currently when you install and active it, .htaccess is installed. However, this file has no purpose when running NGINX as the web server.

    So basically a simple check to the installation process – if the server environment is running NGINX, skip installing .htaccess. Perhaps also a notification on the WordPress Dashboard that for the plugin to work your server environment needs additional configuration -> link to plugin FAQ on wp.org.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @pekkakortelainen,

    Thank you for your message.

    It’s a very good idea and easy to implement. Could you please beta version of plugin for me? First, remove any existing .htaccess files. After adding a new version, plugins should no longer generate.

    Download it from here and install it on your website:
    https://gbiorczyk.pl/webp-converter-for-media-v1.4.3.zip

    The message about the need for additional configuration on the nginx server is already displayed on the plugin settings page.

    Hey @mateuszgbiorczyk

    Didn’t quite expect a response this fast!

    I’ll reset my testing environment so it has no tracks of the plugin being there *ever* at all and then go with installing your beta version. I’ll report back with results.

    Hello!

    Unfortunately with my test the files are still created. Command line output here: https://pastebin.pl/view/a639fc56

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    I assume for WP-CLI the variable $_SERVER['SERVER_SOFTWARE'] I used is not available. Therefore, I am unable to verify your server.

    I suggest you ignore it. This is not a problem in my opinion. There are a lot of unused files in WordPress, and that’s not a problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.