WordPress.org

Forums

Nextend Facebook Connect
[resolved] Feature request: Unlink WP user from social network! (18 posts)

  1. renet
    Member
    Posted 2 years ago #

    Hey there,

    many people don't like it, when they link their Facebook account to their WP user, but are not allowed to unlink it later, if the want to. So my feature request is: Please add the possibility to unlink Facebook accounts (same for Google and Twitter) after they were linked to a WP account.

    But: If this account was auto-created with one of the Nextend Connector plugins and the user has still not specified a password: Force the user to specify a password before the last social network gets unlinked, as otherwise the user cannot login to his WP acount any longer, afterwards.

    Thanks for your great work!

    Regards,
    René

    http://wordpress.org/extend/plugins/nextend-facebook-connect/

  2. nextendweb
    Member
    Plugin Author

    Posted 2 years ago #

    Hi!

    Please update to version 1.4.43. This feature added :)

  3. renet
    Member
    Posted 2 years ago #

    Thank you! But it seems not to work, if an account connection has been made with an older version? At least I can't find the unlink-buttons in my profile... Though I can now see the "Social connect" headline in my profile, but without any content. Can you please take a look at this? Thanks!

    PS: If you added the "force password change" function, as requested: I found that a newly connected user recieves an e-mail with a generated password after he logged in with a social network for the first time. So this feature would no longer be required. (I didn't see the e-mail at first, because it went straigt to my spam folder. :))

  4. nextendweb
    Member
    Plugin Author

    Posted 2 years ago #

    Please go to the plugin settings a save the settings, because the unlink button field added an it doesn't saved by default

  5. renet
    Member
    Posted 2 years ago #

    Ah I see. I have the same problem with some widgets for the theme I'm developing right now. I worked around this by outputting some default value, if the respective settings field is empty (or has not yet been saved).

    It works now. The only thing I don't like is that the user gets logged out automatically, afterwards. Can you please make this optional?

    Also, I saw that you added the unlink function to the Facebook plugin only. It would be great to have it for Twitter and Google, as well. :)

  6. nextendweb
    Member
    Plugin Author

    Posted 2 years ago #

    Okay, I will add the logout to optional parameter also I'm working on the other two plugins too :) It takes some hour to add every features.

  7. nextendweb
    Member
    Plugin Author

    Posted 2 years ago #

    I think about the auto logout function, which was added after the unlink. I agree with you and I think I will remove the logout completely, because the user can unlink their account only if the password, which generated by the social register, were changed. So the logout isn't necessary... Thanks for your idea!

    (Twitter plugin with unlinking is out with v 1.4.43)

  8. renet
    Member
    Posted 2 years ago #

    Thank you for all your effort you put into this plugin! It's really great! Anyway, I have found some issues that came with the unlinking functionality:

    1. If I want to unlink my Google account and click on the unlink-button for the first time, I get to the account selection page of Google (for users with multiple Google accounts) and after I selected the correct account, I get redirected back to my profile, but nothing happened, the account is still linked (not even an error-message). When I click on the unlink button again, it works.

    2. It seems like you redirect to the social network when the unlinking button is clicked. Wouldn't it be enough to just remove the link-data from the database? As the user has to be logged in for that action, there is no need for further verification.

    3. It seems like your "redirect" parameter is no longer working. I always get redirected to the home page, after I successfully linked or unlinked an account. (But only for the "link account" and "unlink account" links in the profile. The login buttons I added to my comment form work fine.)

    4. The unlink function does not work for Twitter, as you forgot to add &action=unlink to the url.

    Sorry for mixing up Google/Facebook/Twitter, but I think that having all unlinking-issues in one post is better.

  9. renet
    Member
    Posted 2 years ago #

    5. There is no info-message, when an account has successfully been unlinked. It would be great, if you added it and also added the possibility to change the info-messages in in the admin area (e.g. for translation purposes).

    6. About the "force password change" function: I think it's not a good idea, as users don't understand why they are forced to change their password in order to unlink an account. A better solution would be to make sure (as you planned it for the Twitter plugin) that a user entered a valid e-mail address, if the address could not be recieved from the social network. This way you ensure, that the user received the auto-generated password when creating a new WP user with your plugin, so "forced password change" is no longer necessary for unlinking an account.

  10. renet
    Member
    Posted 2 years ago #

    Edit about 3.: Sometimes redirection works, sometimes it doesn't.

  11. nextendweb
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the feedbacks! I have considered your ideas and I support them. I is unnecessary to respond every point of your list. I have fixed all of the issues what you wrote also added/modified the features :)

    Please try it out I hope it will be fine for you ;)

    (Latest version from every module, 1.4.47)

  12. renet
    Member
    Posted 2 years ago #

    Thank you, I'll test it, as soon as you allow me to:

    Fatal error: Cannot redeclare new_google_start_session() (previously declared in /home/www/web185/html/loud/wordpress/wp-content/plugins/nextend-google-connect/nextend-google-connect.php:37) in /home/www/web185/html/loud/wordpress/wp-content/plugins/nextend-google-connect/nextend-google-settings.php on line 42

    ;)

  13. nextendweb
    Member
    Plugin Author

    Posted 2 years ago #

    Oh my god! I have just overwritten nextend-google-settings.php with the contents of nextend-google-connect.php

    Fixing it... Thanks!

  14. renet
    Member
    Posted 2 years ago #

    You're welcome. The fatal error is gone now, thanks!

    About the points: 3, 4 and 5 (partly) seem to be ok now. I assume you only fixed these issues for the Facebook and Twitter plugins, but the redirect is still buggy for the Google plugin.

    But behaviour hasn't changed regarding the points 1, 2 and 6. If I can help you fixing these by providing more information, I'd be glad to do so. Just ask. :)

    PS: About point 5 part 2, being able to change/translate the message texts (like "Your Twitter profile is successfully linked ...") in the admin area would really be great, as I am using slightly different terms now. :)

  15. renet
    Member
    Posted 2 years ago #

    About unlinking Google, I just produced this error, when trying to unlink my Google account:

    Fatal error: Uncaught exception 'apiServiceException' with message 'Error calling GET https://www.googleapis.com/oauth2/v2/userinfo?key={removed_by_renet}: (503) Backend Error' in /home/www/web185/html/loud/wordpress/wp-content/plugins/nextend-google-connect/sdk/io/apiREST.php:86 Stack trace: #0 /home/www/web185/html/loud/wordpress/wp-content/plugins/nextend-google-connect/sdk/io/apiREST.php(56): apiREST::decodeHttpResponse(Object(apiHttpRequest)) #1 /home/www/web185/html/loud/wordpress/wp-content/plugins/nextend-google-connect/sdk/service/apiServiceResource.php(187): apiREST::execute(Object(apiServiceRequest)) #2 /home/www/web185/html/loud/wordpress/wp-content/plugins/nextend-google-connect/sdk/contrib/apiOauth2Service.php(42): apiServiceResource->__call('get', Array) #3 /home/www/web185/html/loud/wordpress/wp-content/plugins/nextend-google-connect/nextend-google-connect.php(142): UserinfoServiceResource->get() #4 /home/www/web185/html/loud/wordpress/wp-content/plugins/nextend-google-connect/nextend- in /home/www/web185/html/loud/wordpress/wp-content/plugins/nextend-google-connect/sdk/io/apiREST.php on line 86

    Refreshing made the error go away. Sorrily I am not able to reproduce it. Just thought it might help you.

  16. nextendweb
    Member
    Plugin Author

    Posted 2 years ago #

    I think it was just some error, maybe the Google server was unreacheable.

  17. nextendweb
    Member
    Plugin Author

    Posted 2 years ago #

    PS: About point 5 part 2, being able to change/translate the message texts (like "Your Twitter profile is successfully linked ...") in the admin area would really be great, as I am using slightly different terms now. :)

    Maybe we should add translate support via the usual WordPress translation method what do you think?

  18. renet
    Member
    Posted 2 years ago #

    I think it'd be a good solution. But haven't you already done this? I've looked into your code and found you are using the __($string,$domain) function.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Nextend Facebook Connect
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.