Support » Plugin: IP Geo Block » feature request

  • Resolved alexlii

    (@alexlii)


    Hello,
    there are html5 pages with css 3 on most of the wordpress sites today, and this was intergrated in most of themes, also it is advantage of wordpress theme to sell, even it is a already a standard requirement for theme development on themeforest.com.

    unfortunately, there are always so manny browsers which was slimed on both google store and APPLE store. please search and you will note the truth. the web page with HTML5 and css3 does never work well in those browsers, and the contents will look like a mess.

    so, it would be great if there is a way to detect the user agent so that we can redirect these browses user to a notification page, and ask these to change browser to chrome or firefox or safari.

    The most impotant reason why we need this function is lots of browser was out of update, even they are using chrome, firefox, safari, and rich content and html5 page.will does not display properly either.

    here is a plugin for your referace to.understand the situation we.are.facing.

    https://wordpress.org/plugins/wp-browser-update/

    and those outdate browser does not support ssl with tls 1.2 and 1.3, and this means there will be only a security waninng message, but any non techincial backgroud user do not understand what.happened, they just think.the.site was broken.

    Anyway, it would be great if it support user agent.detect and custom redirect pages.

    what you think?

    thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Hello again @alexlii,

    Although I can understand the background of your request, I think it is out of scope of this plugin.

    1. Theme design issue

    In old days, there were some techniques such as progressive enhancement. Wiki says:

    it allows everyone to access the basic content and functionality of a web page, using any browser or Internet connection, while also providing an enhanced version of the page to those with more advanced browser software or greater bandwidth.

    The JavaScript library Modernizr is definitely for this purpose. For example, Modernizr.testProp() detects if the specific CSS3 property is supported or not by “feature detection” rather than “browser version”.

    So I recommend you to ask the author of WP BrowserUpdate to support “feature detection” for some specific properties.

    2. TLS version issue

    I know this issue is related to security. But I think outdated browser also can be detected by JavaScript. I found the list of versions of browser that supports TLS 1.2 or here in StackOverflow. Alternatively, as a more reliable method, you can also check the server’s environment variables like this.

    I hope these can help you to find the good solution and also appreciate for your kind understanding.

    Thanks.

    alexlii

    (@alexlii)

    Great, I understand now.

    Thanks, and have a nice day.

    Alex

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @alexlii,

    I think you should also refer to the site Can I use to identify which browser’s version supports the specific HTML5/CSS3 feature.

    • This reply was modified 11 months ago by  tokkonopapa.
    alexlii

    (@alexlii)

    Oh, thanks, this is definitely helpful.

    Cheers.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘feature request’ is closed to new replies.