Support » Plugin: XCloner - Backup and Restore » Idea for xcloner settings

  • Resolved ibelyaev

    (@ibelyaev)


    Hello!
    We’ve got a problem with site backups. Once wp size became more than ~130-150mb, cron job interrupts with an error, due to shared hosting limits.
    Tech support replied to our questions, that the servers are set up to stop every process, that make more than 10% processor load in 10 seconds time period.
    The idea is to add to the plugin settings additional option – time limit for backup script execution, and make small pauses in backup process every time the limit is reached. In this case, cron job will take more time, but it would give assurance that everything’s ok, regardless of wp size.
    What do you think about that idea? And is it possible to add this feature to Xcloner?

    Best wishes, Ivan

    • This topic was modified 1 year, 11 months ago by ibelyaev.
    • This topic was modified 1 year, 11 months ago by ibelyaev.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Liuta Ovidiu

    (@xcloner)

    Hi Ivan, it could be possible to have a resume option for cron to continue from where it left off since we already do this using ajax on frontend, but i will have to do more research since the scope of cron was not intended for this.

    So, if i understood correctly: when start backup manually in admin panel, no matter what’s size of a site, the backup process will finish without errors, because the plugin regulate processor load?

    Plugin Author Liuta Ovidiu

    (@xcloner)

    Yes, that should be the case, but please check the XCloner Setting ->System Panel, you can decrease there some parameters in case you run into timeout issues.

    Also, XCloner provide a differential backup option where you could backup only files modified after a certain date, this could work well with your current cron option.

    Ok, thank you!

    • This reply was modified 1 year, 11 months ago by ibelyaev.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Idea for xcloner settings’ is closed to new replies.