WordPress.org

Support

Support » Plugins and Hacks » Plugin Organizer » [Resolved] Feature Request

[Resolved] Feature Request

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jeff Sterup

    @foomagoo

    That’s actually a bug. You should see a trailing slash added to the permalink for the plugin filter. I have it fixed on my version and I’ll release it as soon as I can test it a little more.

    Great and thanks for the testing and update!

    Plugin Author Jeff Sterup

    @foomagoo

    Download version 5.3 and let me know if it fixes your problem. Remember to delete the trailing slash from your permalink.

    Thanks for this update, but yikes!!

    I haven’t been able to get it to work, but more so because when I updated Plugin Organizer via the WordPress interface my site went blank.

    I tried it again on the exact same type of install but different local web address and the same thing happened.

    I was able t pick up and error from an SEO plugin which I will forward to them, but the only way I could get my site back run in the backend was deleting plugin organizer’s /mu-plugins file. I had some wp_debug error that mentioned this file, that is why I tried deleting it. Then everything came back to normal, except no plugins were active at all of course.

    When I reinstalled plugin organizer completely after deleting the mu-plugin file the update and everything worked fine.

    I will try a copy of my install again and updating after deleting the mu-plugin file and one without and record the errors I got for you to look at.

    Plugin Author Jeff Sterup

    @foomagoo

    If your permissions are not set so that the user that the server runs as can write to the file it will have the wrong version in place. It tries to copy the new file when it is activated.

    Okay thanks will try later today!

    I just checked and see that the PluginOrganizerMU.class.php is 644. I will set it to 755.

    Thanks and I will update back for anyone else to view as well.

    Appreciate it!

    I got this to work.

    It is from some other plugin errors I found in debugging.

    I had to delete your plugin first for now and install it again and all works fine.

    Thanks for the help and update, I will check it out now.

    I tried this update and I still get the same thing of plugins not respecting the filter for admin pages.

    Here is what I have set up

    My filter Screenshot.

    My settings Screenshot.

    I am testing as I only want certain plugins to load in the backend when visiting a url related to page/post creation.

    But when I visit any url in the backend all plugins are inactive accept global ones.

    I want only certain plugins to load when on a url like this one > http://localhost/-TroubleShoot/wp-admin/post.php?post=352&action=edit

    What should I change?

    Here is a screenshot of my other url filters.

    Plugin Author Jeff Sterup

    @foomagoo

    You need to delete the / from the end of the permalink.

    Ok.

    I did that but after saving it adds the trailing slash.

    Is this what you meant with the bug?

    I added the url without the slash and it auto added itself.

    Plugin Author Jeff Sterup

    @foomagoo

    Yes. Version 5.3 shouldn’t add that.

    Ok.

    I will try it on a fresh install, maybe it is picking up something from the previous problem and my mu-plugin issue. I will try it out and see.

    If you say ti should work, it should work so I will see where I’ve got the problem.

    Thanks,

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Feature Request’ is closed to new replies.
Skip to toolbar