Support » Fixing WordPress » Feature Images Not Showing in RSS Feed

  • I have created an RSS feed with Feedburner. The images do not display in the feed though. How can I get these to show up?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Please try one of these plugins: https://wordpress.org/plugins/search/enclosure/

    Some themes don’t work very well with featured images in the RSS when you set the feeds for ‘summary’. You can try the full article in the RSS to see but full articles in the RSS sorta defeats the best use of RSS feeds which would be to entice visitors using RSS/Atom to visit the whole article on the site itself to ‘Read More’. That way they visit your site and see other content including those ads you might be running to monetize the site.

    Also, if you have anyone trying to syndicate your content on their site (actually a good thing), they’ll need to run a better system to knock down the import to a Snippet suitable for syndication. As a content aggregator, I’d rather you tell me what I can have than for me to guess with my own settings.

    My advice would be to try a few themes and either settle on one you like all-around or possibly combine the ‘excerpt’ part of that theme into your preferred theme. Always go for ‘summary’ on the RSS except when you are building a site to purposely serve the full article via RSS.

    Joy

    (@joyously)

    Some themes don’t work very well with featured images in the RSS

    Themes do not affect the feed. There are separate functions for that, handled by core.

    My advice would be to try a few themes

    So this advice is not relevant.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.