Support » Plugin: WP Facebook Open Graph protocol » FB Debugger will not scrape my default image

  • Resolved Audrey Clement

    (@audrey-clement)


    I have correctly specified my FB ID and App Ids in the settings of the WordPress Facebook Open Graph protocol plug in. But I get this error message from the FB Debugger no matter what image I specify as the default:

    og:image was not defined, could not be downloaded or was not big enough. Please define a chosen image using the og:image metatag, and use an image that’s at least 200x200px and is accessible from Faceboo… See More

    https://wordpress.org/plugins/wp-facebook-open-graph-protocol/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Chuck Reynolds

    (@ryno267)

    so your Admin ID or App ID has nothing to do with an image. If the page you’re testing isn’t a single post then putting a default image url in the plugin settings will use that image for FB. That image needs to be at least 600 x 315 minimum, as per Facebook best practices.

    I specified a default image that was 2500×2143 in the Facebook Open Graph protocol plugin v2.0.13 settings.

    FB debugger still will not scrape it. The error message is the same:

    “og:image was not defined, could not be downloaded or was not big enough. Please define a chosen image using the og:image metatag, and use an image that’s at least 200x200px and is accessible from Faceboo… “

    Could it be that FB debugger cannot find images stored in the WP Media Library?

    Would if work if I FTPd the image to some other location within my website’s directory structure?

    Plugin Author Chuck Reynolds

    (@ryno267)

    w/o knowing your url to look at I can’t be too much help. maybe the image is being blocked from being seen by the facebook scraper? idk.

    Yea. I think the image is being blocked. The author of the Simple Facebook Connect plug in, which is no longer supported, says it’s probably the theme. But I don’t want to replace the theme, which was purchased from Theme Blossom.

    The URL is:

    Why I’m Running

    Can you take a look?

    Plugin Author Chuck Reynolds

    (@ryno267)

    Okay few things here:

    1. the image you have in settings isn’t an image, it’s a link. You have http://audreyclement.com/sunflower_yellow_kstroke when it should be the actual image ending in .png or .jpg. You’re linking to a page that shows the image, not the image.
    The direct link for that specific image, being served from wp.com is this:
    http://i2.wp.com/audreyclement.com/wp-content/uploads/2016/01/Sunflower_yellow_Kstroke.gif

    2. your admin settings field you have your facebook link, not your facebook user ID. an ID is your ID number, not a link. You have this: https://www.facebook.com/Audrey.R.Clement when you need a number in that field. To find that go here:
    – go to https://facebook.com/insights
    – click “Add Your Domain”
    – in that window that pops up add your site to it but also look at the ID number it displays. put that number, and only that number, in this plugin’s settings.

    3. SO this one is technically optional…. but you don’t need both an Admin ID (#2 above) AND this App ID. You need one or the other. Reason being is what this is doing is telling facebook where you want to track Insights for this domain… either on your personal ID or your App’s ID. So that’s up to you but you don’t need both.

    Do that homework and that should get you going. Cheers! 🙂

    Thanks, Chuck. It works.

    Just donated $50 to your cause.

    Thanks again. Politicos live and die on simple things like links to their blog from FB and vice versa.

    Plugin Author Chuck Reynolds

    (@ryno267)

    Hey I was super busy today but I wanted to thank you very much for that. Definitely didn’t have to do that. But I appreciate it 🙂
    Have a good one! Cheers!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘FB Debugger will not scrape my default image’ is closed to new replies.