Support » Fixing WordPress » Favicon vanished from Posts and other pages, appears only in Homepage

  • diyadebalina

    (@diyadebalina)


    My site https://khanemekyahai.com had been showing favicons for all the pages earlier. I don’t exactly remember when this started happening, but now I see it’s visible only if I am logged in to wp-admin. If I have logged out then it’s visible only for the homepage but not in the other pages or the post pages. Please help. I am working with Kale theme and have uploaded the Favicon through Appearance->Customize->Site Identity->Site Icon
    Please help.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Justina

    (@pokeraitis)

    I would suggest trying to upload a favicon once more – it should be square image, not less than 512x512px.

    After you do that, clean your server / website cache if you use any, and your browser cache. Instructions for clearing your browser cache will be different for each browser and version: https://support.mozilla.org/en-US/kb/how-clear-firefox-cache https://support.google.com/accounts/answer/32050 https://kb.wisc.edu/page.php?id=15141 https://kb.wisc.edu/helpdesk/page.php?id=54747 http://support.wordpress.com/how-to-clear-your-cache-in-safari/

    Another thing, the theme you are using might have it’s own settings for favicon, that override the WP ones, so look through your theme settings and see if there is a place to add favicon there. If it is, follow your theme documentation and upload needed sizes/formats. After that, clean all caches again.

    Hope that helps 🙂

    diyadebalina

    (@diyadebalina)

    I had already done the suggested size and uploaded the photo from the theme settings in Appearance->Customize->Site Identity->Site Icon. However, they were of no help. I am able to see the favicon when in wp-admin, but not when I visit the site. In the website, its only visible in homepage. Please help.

    Justina

    (@pokeraitis)

    Did you clean your cache after uploading?

    Have you checked your theme options for anything related to site icon / favicon?

    Yes, I have cleaned WordPress cache and browser cache. For the Kale theme, I have followed the process and uploaded the favicon through theme settings in Appearance->Customize->Site Identity->Site Icon.
    Still of no help. The favicon was working initially for all the pages. Now its visible only for homepage. Not able to understand what went going wrong.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Favicon vanished from Posts and other pages, appears only in Homepage’ is closed to new replies.