WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Favicon not showing

[Resolved] Favicon not showing

  • Hi

    I’ve read other posts on the topic.
    I did that way
    # Make sure it is named favicon.ico
    # Upload it to the home directory of your site. E.g.: http://op111.net/favicon.ico
    # Install and activate Extended Options
    # Go to Dashboard, Settings, Extended, Favicon Meta Links
    # Select “Favicon in root directory”
    # Scroll down and click Save Changes

    The favicon is dispalyed in the preview, but doesn’t show on browser (Safari and Firefox).

    Theme used is Technical speech
    http:///www.dpwatch.com
    Thanks

Viewing 15 replies - 1 through 15 (of 22 total)
  • Moderator Mark Ratledge

    @songdogtech

    Your page source shows:

    <link rel="shortcut icon" href="http://www.dpwatch.com/wp-content/themes/technical-speech/favicon.ico" />

    so it’s looking for the favicon in the theme folder and not in root – http://www.dpwatch.com/favicon.ico – where the favicon is right now. The “Extended Theme” options are wrong, but you can move the favicon to your theme folder.

    K…so I put the favicon under themes/technical-speech/ and it’s still not showing…
    I may change theme altogether too many troubles with that one!

    Thanks

    Moderator Mark Ratledge

    @songdogtech

    You can manually add favicon code to your header.php like this:

    <link rel="icon" href="<?php bloginfo('siteurl'); ?>/favicon.ico" type="image/x-icon" />
    <link rel="shortcut icon" href="<?php bloginfo('siteurl'); ?>/favicon.ico" type="image/x-icon" />

    and that will always look for the favicon in root.

    ok I put it and still not showing…
    maybe I put this in the wrong place, where excactly in the header.php?
    Thanks

    Moderator Mark Ratledge

    @songdogtech

    header.php is in your theme, but depending on your theme, it might be named something different. What are the files in your theme?

    right on I have the header.php I just don’t know where in the file I should put it.
    Some people told me they were actually seeing the favicon, I just don’t get it.
    The guy fron Bluehost told me he saw it too and could describe it to me (I really saw it 🙂 )

    Moderator Mark Ratledge

    @songdogtech

    I see it in Firefox but not Safari; but those links above in header.php in between wp_head and </head>.

    yup that’s where I put them though.
    Will work on it.
    Thanks

    Sorry to butt in. I’m also having this problem. (New user of wordpress). I’m trying to follow substitute’s instructions but am not sure how to locate the home directory. Also having trouble with ftp settings.
    Any clues?

    Moderator Mark Ratledge

    @songdogtech

    First get FTP working; you can’t do anything without FTP. See FTP Clients « WordPress Codex. Your root diectory is where wp-includes, wp-admin, etc., are located.

    Well my favicon is still there and still not showing.
    I may change theme anyway….
    Thanks

    browsers are set up to support favicons anyway…

    I just dropped my favicon into my root directory, and any other subdomain/directory with websites. My favicon works on all my sites, I’ve never put any code anywhere to tell it to be used….

    OK, I seem to have uploaded it using the built in uploader. I tried classicftp(on mac) but it just crashes. I’m usiong firefox on mac os10.4.11. The fireftp plugin works for my other website but I can’t get the settings right for this one. Does the built in uploader do the trick? The file is certainly there in media with the location http://quallpublications.co.uk/wp-content/uploads/2009/11/favicon1.ico which seems to match what you say above. When I click on the information button next to the url in the browser the media file is there but it is greyed out in italics and does not include the wp-content/uploads/2009/11 part of the location ie. http://quallpublications.co.uk/favicon.ico. I pasted the coding from your post above into the place you say between wp_head and </head> but there is some extra coding between too. It is this: <?php wp_head(); ?>

    <link rel=”icon” href=”<?php bloginfo(‘siteurl’); ?>/favicon.ico” type=”image/x-icon” />
    <link rel=”shortcut icon” href=”<?php bloginfo(‘siteurl’); ?>/favicon.ico” type=”image/x-icon” />

    </head>

    Thanks for the reply. It’s probably something obvious. I’m a new starter.

    Moderator Mark Ratledge

    @songdogtech

    Rvoodoo: it doesn’t always work by dropping a favicon into root; there are things called XHTML standards:Favicon Standardization and implementation

    Bratche: try Cyberduck for FTP with OS X. Don’t use the WP uploader for a favicon. If this code already in your header.php,

    <link rel="icon" href="<?php bloginfo('siteurl'); ?>/favicon.ico" type="image/x-icon" />
    <link rel="shortcut icon" href="<?php bloginfo('siteurl'); ?>/favicon.ico" type="image/x-icon" />

    then leave it and don’t add it again. Your favicon will then work as soon as you get it into the root directory, the same directory that wp-incudes, wp-admin, etc are in.

    waitaminute?? So favicon use is originated by microsoft, which is non standards compliant and now there’s a standard!

    I kid I kid…I was just stating what actually worked for me! But I guess I should update my knowledge and code..

    Thanks songdogtech

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Favicon not showing’ is closed to new replies.