Support » Fixing WordPress » Favicon missing

  • dongermibbs

    (@dongermibbs)


    I have added a .ICO to the root directory. Added it to the theme directory. Tried adding a favicon in the appearance settings in wordpress. Still I cannot get it to show.

    Where am I supposed to place the favicon in my directories via FTP????

Viewing 4 replies - 1 through 4 (of 4 total)
  • JNashHawkins

    (@jnashhawkins)

    Favicons are handled slightly differently in WordPress.

    Here you go… https://codex.wordpress.org/Creating_a_Favicon

    futur3int

    (@futur3int)

    Well best is to put the link in the <head> of your header.php file from your child theme.

    as per follow:

    <link rel="shortcut icon" href="<?php echo (get_bloginfo('stylesheet_directory'). '/images/favicon.ico');?>" type="image/x-icon">

    And put the favicon.ico file via your FTP in your childthemedirectory/images/

    Goodluck

    • This reply was modified 1 year ago by futur3int.
    • This reply was modified 1 year ago by futur3int.
    wp-muhkiainen

    (@toppahattu)

    You can put favicon.ico into your theme folder too.

    dongermibbs

    (@dongermibbs)

    Unfortunately none of those work.

    I’ve tried putting it in wp content/themes/theme name/assets/images

    Nothing shows up despite clearing the cache or trying to use a different browser.

    To make matters worse, when I try and use Appearance/Customize in dashboard, I can set the favicon but there is no save button anywhere.

    Instead, I can see text behind an image of my site which is only partially readable. But after some effort I discovered it says:

    Notice: Trying to get property of non-object in /home/username/public_html/sitename.com/wp-includes/nav-menu.php on line 780

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Favicon missing’ is closed to new replies.