Support » Plugin: The SEO Framework » favicon missing

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Sybre Waaijer

    (@cybr)

    Hi Pedro,

    The “Site Logo” is used, not the “Site Icon”.

    WordPress does make a distinction between the two, and it’s up to the theme to support this functionality. Check out the Custom Logo documentation for more information.

    I didn’t include the Site Icon because–unlike the logo–that image isn’t meant to fit the site’s UI, like the sitemap’s color-scheme should. Instead, it should fit browser tabs and mobile device home screens.

    Hi Sybre,

    But “Site Logo” and “Site Icon” aren’t it for different purposes?

    Site Icons are what you see in browser tabs, bookmark bars, and within the WordPress mobile apps. Upload one here!
    Site Icons should be square and at least 512 × 512 pixels.<

    (http://prntscr.com/k2i4vm)

    Using a custom logo allows site owners to upload an image for their website, which can be placed at the top of their website.

    From these definitions my interpretation is: http://prntscr.com/k2i80d

    Would you agree?

    The favicon missing of my initial question is the “Site Icon”.

    Thanks

    Plugin Author Sybre Waaijer

    (@cybr)

    Hi Pedro,

    My apologies, I thought you meant the icon placed next to the user-facing title on the page, as shown here: https://theseoframework.com/sitemap.xml

    I’m not sure if the sitemap stylesheet would allow a favicon. It’d be a great addition, which I’ll look into. So, I’ve opened an enhancement issue for the next update:
    https://github.com/sybrew/the-seo-framework/issues/334

    In the meantime, adding a favicon.ico, .png or .gif file to your website’s root folder should resolve the issue.

    Cheers 🙂

    Hi Sybre,

    Done!

    I thought it would be added by some other way then placing the favicon.ico file at the root of the website since we already had the Site Icon in every other page. Anyway, it’s working now.

    Thanks.

    Cheers 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘favicon missing’ is closed to new replies.