Support » Fixing WordPress » Favicon is changed in version 5.4

  • Many of our clients had the favicon changed after updating to the version 5.4.

    Anyone having the same issue? WordPress replaces it with WP logo for some reason…

Viewing 15 replies - 1 through 15 (of 15 total)
  • I’ve not experienced this.

    Is this happening in the admin dashboard or on the front end?

    Can you share the URL of one of these sites still having the issue?

    Thread Starter Cezar Ayran

    (@ayrancd)

    Front/Back-end I already fixed all of them.

    I am having the issue after updating to WordPress 5.4. The default WP favicon won’t go away. The image was deleted from my Media Library, replaced by a new image. However the default WP favicon persists and it is still in the wp-includes/images folder on the server. It is slowing my site down. Go here to see: https://bluelapisevents.com

    • This reply was modified 10 months, 3 weeks ago by ekdavis808.

    I’m seeing this issue on a lot of sites, both those I manage for clients and others. No changes on any of the sites from our side but all favicons changed to the WP logo.

    After updating to our own favicons, it also still switches back and forth between the WP default logo and the new updated custom icon on Admin.

    Yep, I have noticed this on several sites as well that have been updated to 5.4.

    stevenhermans

    (@stevenhermans)

    It is very persistent. I also have it popping up on my PHPBB forum – I don’t even know how that’s possible.

    This code and plugin might help:

    https://gist.github.com/webdados/a7702e588070f9a1cfa12dff89b3573c
    https://wordpress.org/plugins/wp-favicon-remover/

    stevenhermans

    (@stevenhermans)

    Had a deeper look. The plugin and code above do not solve the issue because pdf files or images, and also the WP backend will still have the WP favicon.

    The only solution is to upload a favicon.ico to your root folder via FTP.

    Thread Starter Cezar Ayran

    (@ayrancd)

    still happening…

    parisaaxp

    (@parisaaxp)

    I have the same problem, after updating wordpress, my login page and my WordPress panel’s favicon changed into this blue wordpress default icon

    also “WP favicon remover” didn’t work for me. nothing happened.
    I cleared my cache many times but still nothing.

    HELP!

    Thread Starter Cezar Ayran

    (@ayrancd)

    You must add the favicon again. Usually: Appearance > Customize

    Have the same issue as well on 5.4.2, I have tried setting through

    Appearance > Customize
    Appearance > Theme Options

    and I see it show up for a second then revert back, the only way I was able to fix it was using this plugin which stinks as I now need a plugin to just have the right favicon

    Favicon by RealFaviconGenerator

    • This reply was modified 7 months, 3 weeks ago by gh0stshell.

    Just figured it out! Well at least a fix, activate a default theme, I chose 2020 and then go to

    Appearance > Customize > Site Identity > Site Icon

    once I set it there when I enabled my theme it stuck and is working!

    seems to be a themes issue since the default 2020 is working just fine and it is my non WP themes that are not working

    It’s quite annoying to see that W favicon –my website even has a designated area to add my own favicon but it refuses to acknowledge anything other than the WordPress W. Ugh! My clients are wanting it to go away and its been this way for a month now. https://sodsuppliers.com If someone figures it out please let me know.

    • This reply was modified 2 months, 1 week ago by bestkarma.
    Thread Starter Cezar Ayran

    (@ayrancd)

    @bestkarma I see the favicon code:

    <link rel="shortcut icon" href="https://sodsuppliers.com/wp-content/uploads/2020/12/georgia-sod-farm-wholesale-cost-zoysia.png" type="image/x-icon"><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>

    This is the image popping up in my browser: view-source:https://sodsuppliers.com/wp-content/uploads/2020/12/georgia-sod-farm-wholesale-cost-zoysia.png

    AliceAliceAlice

    (@alicealicealice)

    Hi all,

    I updated to WP 5.6.1 and suffered the irritating WP W-favicon displaying on just the front end of my website as well.

    After doing these things (multiple times):

    • clearing WP and browser caches
    • deleting/reloading the original favicon as well as new favicon images (including a 32×32) — all using the Theme Customizer / Site Identity process
    • regenerating thumbnails
    • running an online favicon test (https://realfavicongenerator.net)

    I remembered having recently added code to my website’s <head> to remove the unwanted alt-titles displaying on hover across my website (without deleting them entirely and losing their alt-title SEO benefits).

    This is the alt-title code I had added:

    jQuery(document).ready(function($) {
    $(‘img[title]’).each(function() { $(this).removeAttr(‘title’); });
    });

    When I deleted the alt-title code — POOF! — my favicon returned. I’m not sure why that code affected things but it seems it did.

    The other thing it might be is that I run an independent theme (Divi) which has also been upgraded recently. I’m still not sure if the favicon issue is a WP or theme related occurrence.

    If anyone has info to share about the favicon puzzle and/or how to successfully remove the alt-titles at hover, I’d really appreciate hearing from you!

    Many thanks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.