WordPress.org

Support

Support » Installation » [Resolved] Faulty insallation causing log in problems?

[Resolved] Faulty insallation causing log in problems?

Viewing 15 replies - 1 through 15 (of 15 total)
  • xanderini

    @xanderini

    Having put my blog through validation on here t comes up with 17 errors. Unfortunately none of it means a thing to me as I don’t know how to code php. My limited understanding of programming makes me think that many of the errors listed are suggestions and not actual errors per se but if someone could have a look and give me a nude in the right direction I’d be most grateful.

    whooami

    @whooami

    Member

    you need to upload wp-blog-header.php

    it needs to be in the same directory as your wp-config.php and index.php are in (the root of your wordpress install)

    xanderini

    @xanderini

    I need to move all three files to the root?

    Okay I’ll give it a go.

    Thought I was just supposed to redirect by editing the index file though?

    Thanks.

    whooami

    @whooami

    Member

    you need to upload wp-blog-header.php

    your replies belies your problem.

    you should NOT need to move any files.

    xanderini

    @xanderini

    Sorry I’m obviously missing something obvious here. I moved the files back, reset them to standard and yet the blog fails to load. I was under the impression that if the directory of the files was different to the url loaded then you had to alter the index file. You seem to be saying that this is wrong but now I can’t access anything on the blog at all!

    xanderini

    @xanderini

    Okay the only way this works is by having my files in one folder, the blog altered to redirect to the root and the index.php file altered to reference the wordpress folder. However I still cannot log on.

    whooami

    @whooami

    Member

    you have wordpress in its own directory?

    in the case you would have 2 index.php files — BOTH of which need to correctly point to your wp-blog.header.php.. and your wp-blog-header.php goes in the directory that your wp-config.php and ONE index.php are in.

    Since you only have ONE wp-config.php, theres no way for me to suggest that wp-blog-header.php goes anywhere else.

    I said nothing about editing any files. I said nothing about redirecting. etc..

    This appears to be your problerm:

    Where are your wordpress files in relation to your wp-config.php? If they are in a subdirectory, then the path that needs to go in your ROOT index.php is:

    require('./subdirectory/wp-blog-header.php');

    where subdirectory is changed to the name of your actual directory.

    THIS is all covered in the codex.

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    see #9

    xanderini

    @xanderini

    Thanks.

    I’ve done this and the problem still remains.

    I think I’m back to where I started. I may have copied the index not moved it.

    Either way the blog runs fine with no error displayed but it’s still impossible to be logged in to the blog and view it.

    whooami

    @whooami

    Member

    you have TWO index.php files, correct? one in the directory with your wp-config.php and one in the root directory — I presume above that OTHER directory?

    what do the each of them read, as far as this line goes:

    require('./wp-blog-header.php');

    youre REALLY not helping here —

    how about tell me the dir so I can actually refer to it by name?

    how about sharing the domain name..

    etc..

    whooami

    @whooami

    Member

    forget the last.. Ive already explained what the problem is. Its up to you to follow the directions to fix it.

    so here we go again with those directions.

    if you have wordpress installed in its own directory. (which you have yet to confirm. apparantly you want to be obtuse):

    then you will have TWO index.php files — one in the root of your webspace and one in whatever subdirectory.

    BOTH those files need to correctly include wp-blog-header.php

    wp-blog-header.php should reside inside the directory that contains your wp-config.php

    Ive shown you an example above, and there is also one in the codex (linked to above).

    Best of luck!

    xanderini

    @xanderini

    Thank you. I have done as you instructed to the letter.

    I have one index file in the subdomain x-hub with the path to the blog header as ./wordpressfiles/wp-blog-header and then another index file in the wordpressfiles folder which has the path as ./wp-blog-header.

    Unfortunately this doesn’t seem to have fixed the problem.

    I also toggled the cache to disabled and then enabled it again to refresh that and I also disabled and then reenabled the gears to check if that was delivering non refreshed content. Still no luck.

    Thank you for your efforts though.

    whooami

    @whooami

    Member

    wp-blog-header.php

    xanderini

    @xanderini

    Yup. Sorry I was rather dumbly thinking that actually having the file name with suffix would cause problems… brain fart, sorry.

    xanderini

    @xanderini

    Problem solved I created a new subdomain and instructed that to keep all the files elsewhere. Works perfectly.

    Hi Xanderini and whooami,

    I’m not sure if I’m having the exact same issues xanderini described. But, I’m new to WordPress. I originally installed WordPress at my root level. Then I moved it using the directions outline here: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory.

    The only difference is that I want my blogs to be displaying elsewhere and not root level. (http://www.enjam.com/blogs)
    I have all the WordPress files in (http://www.enjam.com/wordpress/).

    I can access the dash board and everything okay. But, when I try to access my blog, these are the error messages I receive.
    _________
    Warning: require() [function.require]: URL file-access is disabled in the server configuration in /export/home/li/libreseele/public_html/blogs/index.php on line 17

    Warning: require(http://www.enjam.com/wordpress/wp-blog-header.php) [function.require]: failed to open stream: no suitable wrapper could be found in /export/home/li/libreseele/public_html/blogs/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required ‘http://www.enjam.com/wordpress/wp-blog-header.php’ (include_path=’.:/usr/local/php5cgi/lib/php’) in /export/home/li/libreseele/public_html/blogs/index.php on line 17
    ________

    After reading this particular post, I now have index.php, wp-blog-header.php, wp-config.php and .htacess in both the blogs and WordPress folders.

    I checked to make to sure that the code (in wp-config.php) to direct to the file wp-blog-header.php is correct.

    Please advise and help.

    Thanks

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Faulty insallation causing log in problems?’ is closed to new replies.
Skip to toolbar