Support » Plugin: WP REST Cache » Fate error after recent WordPress automated – 5.2.4 security update

  • Resolved Rory Michael Heaney

    (@rorymheaney)


    Fatal error: Uncaught Error: Call to undefined function is_user_logged_in() in /var/www/html/wp-includes/rest-api.php:591
    
    Stack Trace
    1.	
    rest_send_cors_headers('')
    /var/www/html/wp-content/plugins/wp-rest-cache/includes/api/class-endpoint-api.php:291
    2.	
    WP_Rest_Cache_Plugin\Includes\API\Endpoint_Api->get_api_cache()
    /var/www/html/wp-content/mu-plugins/wp-rest-cache.php:25
    3.	
    include_once('/var/www/html/w...')
    /var/www/html/wp-settings.php:293
    4.	
    require_once('/var/www/html/w...')
    /var/www/html/wp-config.php:97
    5.	
    require_once('/var/www/html/w...')
    /var/www/html/wp-load.php:37
    6.	
    require_once('/var/www/html/w...')
    /var/www/html/wp-blog-header.php:13
    7.	
    require('/var/www/html/w...')
    /var/www/html/index.php:17
    8.	
    {main}
    thrown in /var/www/html/wp-includes/rest-api.php on line 591

    Not sure if this is me, or a clash with the latest update. My site has been using the cache plugin for several months without an issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • I can confirm on another project that I get the same error after upgrading to WP 5.2.4

    yclaes

    (@yclaes)

    Same here. Issue occurs on multiple WordPress instances. Disabled the plugin for now.

    Plugin Author Richard Korthuis

    (@rockfire)

    Hi @rorymheaney and @yclaes

    Thank you for using our plugin!

    We are investigating the issue and hope to release a fix later today.

    Nurgiel

    (@nurgiel)

    Same issue, gotta disable these auto updates on production God dammit.

    Plugin Author Richard Korthuis

    (@rockfire)

    Hi @nurgiel @yclaes @rorymheaney

    We just released a new version of our plugin, which should solve this issue. Please let us know if you still have any problems!

    Update worked great, really appreciate it!

    fighter1

    (@fighter1)

    I’m having the same issue with my website. Error message below:

    Fatal error: Uncaught Error: Cannot access empty property in /homepages/13/d232447960/htdocs/clickandbuilds/ChapelOnTheWeb/wp-content/themes/themify-ultra/themify/themify-wp-filters.php:569 Stack trace: #0 /homepages/13/d232447960/htdocs/clickandbuilds/ChapelOnTheWeb/wp-includes/class-wp-hook.php(286): themify_hide_themes(Array, ‘https://api.wor…’) #1 /homepages/13/d232447960/htdocs/clickandbuilds/ChapelOnTheWeb/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array) #2 /homepages/13/d232447960/htdocs/clickandbuilds/ChapelOnTheWeb/wp-includes/class-http.php(222): apply_filters(‘http_request_ar…’, Array, ‘https://api.wor…’) #3 /homepages/13/d232447960/htdocs/clickandbuilds/ChapelOnTheWeb/wp-includes/class-http.php(589): WP_Http->request(‘https://api.wor…’, Array) #4 /homepages/13/d232447960/htdocs/clickandbuilds/ChapelOnTheWeb/wp-includes/http.php(187): WP_Http->post(‘https://api.wor…’, Array) #5 /homepages/13/d232447960/htdocs/clickandbuilds/ChapelOnTheWeb/wp-includes/update.php(521): wp_remote_post(‘h in /homepages/13/d232447960/htdocs/clickandbuilds/ChapelOnTheWeb/wp-content/themes/themify-ultra/themify/themify-wp-filters.php on line 569

    Plugin Author Richard Korthuis

    (@rockfire)

    Hi @fighter1

    I am afraid your error is different from the error mentioned in the start post of this topic. As you can see in your error message, you get an error in wp-content/themes/themify-ultra/themify/themify-wp-filters.php. So this error seems to be related to your theme and not to our plugin.
    I wanted to see if I could find the exact cause of your error, but unfortunately you are using a paid theme, so I don’t have access to the source of the theme. I am afraid I can’t help you with this error.

    fighter1

    (@fighter1)

    Ah, makes sense. Thank you, Richard. I will reach out to Themify

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Fate error after recent WordPress automated – 5.2.4 security update’ is closed to new replies.