Support » Plugin: Panorama - WordPress Project Management Plugin » Fatal undefined functions errors

  • Resolved Ed

    (@eammendola)


    I’m getting errors in the front and back end with this plugin. I really would like to use it, but it is not unusable at the moment.
    I can’t upload images here, but here is a sample of the errors:

    ( ! ) Fatal error: Uncaught Error: Call to undefined function get_field() in C:\wamp64\www\intranet\wp-content\plugins\project-panorama-lite\lib\psp-helpers.php on line 441
    ( ! ) Error: Call to undefined function get_field() in C:\wamp64\www\intranet\wp-content\plugins\project-panorama-lite\lib\psp-helpers.php on line 441
    Call Stack
    # Time Memory Function Location
    1 0.0156 486176 {main}( ) …\edit.php:0
    2 3.2293 95437616 WP_Posts_List_Table->views( ) …\edit.php:357
    3 3.2293 95438704 apply_filters( ) …\class-wp-list-table.php:375
    4 3.2293 95439104 WP_Hook->apply_filters( ) …\plugin.php:203
    5 3.2293 95440496 psp_update_project_quicklinks( ) …\class-wp-hook.php:286
    6 3.2449 95497728 psp_my_projects_overview( ) …\psp-data-model.php:246
    7 3.2917 95512328 psp_compute_progress( ) …\psp-helpers.php:1017

    -AND-

    ( ! ) Fatal error: Uncaught Error: Call to undefined function get_field() in C:\wamp64\www\intranet\wp-content\plugins\project-panorama-lite\lib\templates\archive-psp_projects.php on line 18
    ( ! ) Error: Call to undefined function get_field() in C:\wamp64\www\intranet\wp-content\plugins\project-panorama-lite\lib\templates\archive-psp_projects.php on line 18
    Call Stack
    # Time Memory Function Location
    1 0.0156 385824 {main}( ) …\index.php:0
    2 0.0156 387856 require( ‘C:\wamp64\www\intranet\wp-blog-header.php’ ) …\index.php:17
    3 5.9282 83956224 require_once( ‘C:\wamp64\www\intranet\wp-includes\template-loader.php’ ) …\wp-blog-header.php:19
    4 5.9282 84185304 include( ‘C:\wamp64\www\intranet\wp-content\plugins\project-panorama-lite\lib\templates\archive-psp_projects.php’ ) …\template-loader.php:74

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author 3pointross

    (@3pointross)

    Hello,

    Thanks for the heads up on this – this is really strange.

    It looks like the custom field library included in Panorama Lite is not loading which I suspect could be one of two reasons:

    • Did you manually upload the Panorama files through FTP? If so maybe not all of them uploaded?
    • Is it possible you have advanced custom fields uploaded on your site but not active?

    If neither of those seem right, can you try installed Advanced Custom Fields on your site? https://www.advancedcustomfields.com/

    That will load the custom field library separately and should correct this issue.

    Ed

    (@eammendola)

    Thanks for the very quick response! I installed Advanced Custom Fields plugin and everything appears to working correctly for Panarama, but now I’m having issues with another plugin, LogicalDOCS. If I deactivate Advanced Custom Fields, LogicalDOCS starts working again. I don’t expect you to debug Advanced Custom Fields or LogicalDOCS errors, so I’ll contact support for those. Hopefully I can get it sorted out, I was really counting on these components. Once again, thanks for the quick response.

    Plugin Author 3pointross

    (@3pointross)

    Ah, I was afraid this might be the case – it sounds like LogicalDOCS is either also using Advance Custom Fields in a similar but incompatible way or it’s using the same function names that ACF does.

    They might have a solution on their end?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fatal undefined functions errors’ is closed to new replies.