Support » Fixing WordPress » Fatal … undefined function wp_get_current_user() in wp-includes/user.php 223

  • Resolved cullaloe


    I have a WPMU installation, which I have just upgraded to WP3.0. I have multiple domains using the same installation but *some* of the non-primary domains are broken with the above error displayed instead of [anything!].

    I’ve tried messing about with plugins, even disabling them through the database – no change.

    I used the automatic upgrade on the primary domain ( All of the blogs, er, sorry, “sites”, on this domain work fine, e.g.,

    In the dashboard of the sites, “my sites” displays all of the sites across the entire installation. In the super admin “sites” menu, only the sites in the current domain (, are shown. This seems backawrds to me?

    Anyway, any ideas what to try next please?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Still digging.

    The updated blogs which work OK all have db_version 15260, which I guess would be the 3.0 version. The two blogs which do not work are (a) located in the root directory and (b) have db_version 12329.

    Is there a script I can run manually to upgrade these two sites?



    OK. This is what I did to fix this.

    Using php-myAdmin, updated wp_blogs such that the site_id=1 (the main blog).

    Then, visited each site and ran the /wp-admin/update.php script. This updated the database version to the current value (in blog_versions, db_version=15260)

    Then ran the database repair script /wp_admin/maint/repair.php to check it was all hunky dory.

    All the sites *seem* to be working OK now.

    I had the same problem, but it appeared just after uploading the WP-reCaptcha files. So removing them had solved it.
    Well so, it seems to be a bug of the plugin or an incompatibility with WordPress MU 3.0.
    Digging it… .

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fatal … undefined function wp_get_current_user() in wp-includes/user.php 223’ is closed to new replies.