• Resolved scratchmaster

    (@scratchmaster)


    Hello,

    I just tried to activate Style Kits for Elementor and received this Fatal PHP error:

    `Fatal error: Uncaught Error: Call to a member function is_built_with_elementor() on bool
    in /home/runcloud/webapps/xxxxx-staging/wp-content/plugins/analogwp-templates/inc/elementor/class-tools.php on line 209

    Call stack:

    Analog\Elementor\Tools::stylekit_post_state()
    wp-includes/class-wp-hook.php:307
    WP_Hook::apply_filters()
    wp-includes/plugin.php:191
    apply_filters()
    wp-admin/includes/template.php:2249
    get_post_states()
    wp-includes/nav-menu.php:826
    wp_setup_nav_menu_item()
    array_map()
    wp-includes/nav-menu.php:750
    wp_get_nav_menu_items()
    wp-includes/nav-menu-template.php:151
    wp_nav_menu()
    wp-includes/widgets/class-wp-nav-menu-widget.php:109
    WP_Nav_Menu_Widget::widget()
    wp-includes/class-wp-widget.php:393
    WP_Widget::display_callback()
    wp-includes/widgets.php:835
    dynamic_sidebar()
    wp-content/themes/buddyboss-theme/template-parts/footer.php:13
    require()
    wp-includes/template.php:772
    load_template()
    wp-includes/template.php:716
    locate_template()
    wp-includes/general-template.php:204
    get_template_part()
    wp-content/themes/buddyboss-theme/inc/theme/template-functions.php:670
    buddyboss_theme_footer_area()
    wp-includes/class-wp-hook.php:307
    WP_Hook::apply_filters()
    wp-includes/class-wp-hook.php:331
    WP_Hook::do_action()
    wp-includes/plugin.php:476
    do_action()
    wp-content/themes/buddyboss-theme/footer.php:23
    require_once()
    wp-includes/template.php:770
    load_template()
    wp-includes/template.php:716
    locate_template()
    wp-includes/general-template.php:92
    get_footer()
    wp-content/plugins/elementor/modules/page-templates/templates/header-footer.php:30
    include()
    wp-includes/template-loader.php:106
    require_once()
    wp-blog-header.php:19
    require()
    index.php:17

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter scratchmaster

    (@scratchmaster)

    Please let me know what you think… I would love to use Style Kits for Elementor! It looks like a fantastic tool, and if I can get it to work on my personal site, then I’ll also consider a Pro license. 😁👍

    Please look into the error above, and let me know what might be causing it.

    Thread Starter scratchmaster

    (@scratchmaster)

    It could be only happening on pages that were imported from a previous site build… Would that make sense?

    Thread Starter scratchmaster

    (@scratchmaster)

    The above is not true… It’s simply that if I create a new page, then it works. But then as soon as I change it from Canvas to Full-Width in Elementor, then this error occurs. I then have to deactivate Style Kits, put it back into Canvas mode, and then activate Style Kits.

    Is this a known problem? Or do we always have to edit pages in Canvas mode whilst using Style Kits?

    Thanks for your help.

    Kind regards

    Plugin Support Krishna Kant Chourasiya

    (@lushkant)

    Hi there @scratchmaster

    Thank you for notifying us, as per our last support conversation this issue has been addressed in the coming update v1.9.5.

    Anyone facing the same issue should update Style Kits to v1.9.5 or higher to resolve this.

    Hope this helps!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fatal PHP error when activating Style Kits’ is closed to new replies.