Support » Plugin: Molongui Authorship » Fatal PHP error on update to 2.2.1 (500)

  • When my site auto-updated, I got a 500 error. PHP errors:

    PHP Warning: require_once(/opt/sites/foo/bar/wp-content/plugins/molongui-authorship/fw/includes/fw-class-compatibility.php): failed to open stream: No such file or directory in /opt/sites/foo/bar/wp-content/plugins/molongui-authorship/molongui-authorship.php on line 82 
    Warning: require_once(/opt/sites/foo/bar/wp-content/plugins/molongui-authorship/fw/includes/fw-class-compatibility.php): failed to open stream: No such file or directory in /opt/sites/foo/bar/wp-content/plugins/molongui-authorship/molongui-authorship.php on line 82 
    PHP Fatal error: require_once(): Failed opening required '/opt/sites/foo/bar/wp-content/plugins/molongui-authorship/fw/includes/fw-class-compatibility.php' (include_path='.:/usr/local/php7.0/lib/php') in /opt/sites/foo/bar/wp-content/plugins/molongui-authorship/molongui-authorship.php on line 82 
    Fatal error: require_once(): Failed opening required '/opt/sites/foo/bar/wp-content/plugins/molongui-authorship/fw/includes/fw-class-compatibility.php' (include_path='.:/usr/local/php7.0/lib/php') in /opt/sites/foo/bar/wp-content/plugins/molongui-authorship/molongui-authorship.php on line 82

    This is on wordpress.com btw. I got the error messages from support, so I don’t have ongoing access to logs. I can give environment data if that’s helpful.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Molongui

    (@molongui)

    Hi llis,

    That error is caused because the plugin is trying to load a file that seems not to be present on your server… which is weird because it is on plugin installer/updater.

    Do you have any cache plugin or mechanism you can empty? If so, do that and try again, please.

    Anyway, please, open a support ticket on our site (here) so we can look into this the soonest. No one else has reported this, so I think this might be something from your installation.

    Thanks!

    The installation is on wordpress.com. Would that affect the path expected (vs a core WordPress install)? I’m just guessing. (In the code above, “foo” and “bar” replace indentifying info for my account and site. The support person pasted the PHP log errors for me and I anonymized them and passed them along here.)

    I could try deleting and reinstalling, but I’ll have to wait until I can deal with 5–10 min of wsod in case it happens. Unfortunately I don’t have a dev environment set up to test on since .com is a kind of do-it-all-hot arrangement.

    Plugin Author Molongui

    (@molongui)

    Hi llis,

    the plugin’s main file is being loaded, so it shouldn’t be a path issue. My guess is that file got moved, deleted or inaccessible for some reason. As you work with WP.com, you don’t have FTP access so I’m not sure how would you be able to check which files are on the plugin directory.

    Anyway, you should be safe reinstalling the plugin without loosing any data. Just make sure to have the “Keep configuration?” and “Keep data?” settings set to “Yes” (those settings are available on the “Advanced” tab of the plugin settings page). Nonetheless, it is always advisable to perform a backup of your database installation before reinstalling.

    Thanks for the quick reply. After nearly 15 years of code maintenance, I’m enjoying hosting with ridiculously fast and competent support and no code maintenance involved, with the rare exception of plugins that for some reason don’t auto-update. The downside is that I’m less helpful in situations like these.

    I will try the reinstall in the next few days and update what happens here.

    Thanks again.

    Plugin Author Molongui

    (@molongui)

    Hi there!

    I’m closing this thread because no one has reported any issue similar to this and we got no feedback from you.

    Feel free to contact us again if you need further assistance.

    Regards,
    Molongui Team Support

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal PHP error on update to 2.2.1 (500)’ is closed to new replies.