Support » Plugin: User Spam Remover » Fatal PHP error about mysqli on activation

Viewing 1 replies (of 1 total)
  • Plugin Author joelhardi

    (@joelhardi)

    This is by design! That is an error message I have written to help you!

    Please see the documentation. The original PHP mysql extension was deprecated in PHP 5.5 and is unsafe, it does not support transactions, which are required to safely modify the database, preserve data integrity and permit rollback.

    MySQLi was introduced in PHP 5.0 in 2004 and has been fully supported by WordPress or a long time.

    It’s not my business why why you’re still using the old MySQL extension, which is unsafe, when there has been a better version available for over 10 years. The old extension was removed in PHP 7.0 so at some point you’ll have no choice but to upgrade.

    Please consider reviewing my plugin again once you’ve looked at the requirements, install instructions, or reviewed the support threads where I address this issue many times.

Viewing 1 replies (of 1 total)
  • The topic ‘Fatal PHP error about mysqli on activation’ is closed to new replies.