Support » Plugin: Easy Contact PopUP » Fatal Parse Error since update

  • Resolved airforceadvice

    (@airforceadvice)


    Since your update yesterday I have had to disable your plugin as it broke my site and was not functional. The error I get is

    Parse error: syntax error, unexpected ‘class’ (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or ‘{‘ or ‘$’ in /home/wwwwebsitename/public_html/wp-content/plugins/easy-contact-popup/inc/EasyContactPopup.php on line 29

    I have uninstalled and reinstalled but nothing will work.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Sleepless Developer

    (@brainmadeltd)

    Hello,

    Sorry for the issue.

    That error usually when an outdated version of PHP is installed on the server. The easy contact popup plugin requires PHP version 7.0 or higher. Please contact your hosting provider about this.

    Hope that helps. if you have any question, please feel free to ask.

    Thank You.
    Brain Made

    Same issue, I am running PHP version 7.0.30 but your plugin is crashing my site.

    I would like to use your plugin as it has been our solution for lead-capturing contact forms and I don’t want to have to figure out a different workflow…

    …but are you just going to ignore this issue?

    hello bryan,

    i spoke to hostgator who were very heloful. we did what you said but to no avail.

    your instructions were wrong. is there a way to revert back to the old more stable plugin before the update?

    also to anybody else reading this, could you please let me know of any alternative plugins you used as Im not sure this plugin will work in future.

    Can confirm that my site was crashed as well. Please remove this version 2.0.3. from updater until you fix issue.
    —————-
    Last update brakes site – Can’t open page after update. I updated several plugins and wasn’t sure which brakes site. Then I started to update every plugin separately and finally found this update destroy site. I checked for several times invluding updateting after I updated wordpress. This last Update (ou have version 1.0.1 installed. Update to 2.0.3.) is doing website broken.
    ————

    Andrey

    PHP version 7.0

    WARNING: DO NOT USE THIS PLUGIN… This author ignores problem s he does not know how to fix and this formerly terrific plugin now CRASHES websites, multiple posts on here explaining that. An easier and better alternative to this plugin is SLICK POPUP free version.

    Plugin Contributor Sleepless Developer

    (@brainmadeltd)

    Sorry for the delayed reply.

    We have solved fatal error problem and we tested with PHP 5.6 and PHP 7.0 version it worked. Please tell if you still face the problem or if you have any question, please feel free to ask.

    Thank You.
    Brain Made

    we still have the problem, it crashes our site.. php 7.0 with your latest version. however version 1.0.1 is working perfectly

    Agreed – latest update (V2.0.3) does cause 500 fatal server error. PHP 7.0.x

    Rollback to V1.0.1 and is working on WP 4.9.8

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Fatal Parse Error since update’ is closed to new replies.