Support » Fixing WordPress » Fatal error: xml_parser_create, and Dashboard now empty

  • I host a WordPress blog on my own FreeBSD 4.7 server running Apache 1.3 with mod_php5 installed; my PHP is version 5.1.2 and phpinfo() shows that I have libxml support:

    libxml

    libXML support => active
    libXML Version => 2.6.23
    libXML streams => enabled

    Up until recently everything has always worked flawlessly, through WordPress 1.2 right up to WordPress 2.0. However, a botched Java install on my server has played havoc with all manner of things, and I’ve had to reinstall several things from the FreeBSD ports collection to get back up and running.

    I thought all was well after the latest round of reinstallations, but now whenever I post to my blog, I get the following error:

    Fatal error: Call to undefined function xml_parser_create() in /usr/www/sisko.org/htdocs/wp-includes/class-IXR.php on line 144

    The post does appear on my blog, but I can only assume that something’s not working, e.g. pinging blo.gs, etc.

    Also, and I’m sure relatedly, my dashboard is now completely blank, other for the headings ‘Dashboard’ and ‘Latest Activity’.

    Any ideas what I can do to get things up and running again?

    Thanks!

    Daniel

Viewing 1 replies (of 1 total)
  • Is anybody able to help me with this problem? It’s been a week and I’m still suffering from the same symptoms.

    Thanks for any help that can be offered!

    Daniel

Viewing 1 replies (of 1 total)
  • The topic ‘Fatal error: xml_parser_create, and Dashboard now empty’ is closed to new replies.