Support » Fixing WordPress » Fatal error – wrong settings

  • I know that this problem was solved, but on my WordPress it doesn’t work.
    I use this gallery polugin:
    and pictures upload correct, but when I want to public my gallery I can see this text:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 14400 bytes) in /home/dazinf/domains/ on line 258

    I have changed upload_max_filesize and post_max_size for 32MB on my PHP settings and added “define(‘WP_MEMORY_LIMIT’, ’32M’)” on wp-config.php.

    Sorry for my english, I still learn. I hope you understand.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Sounds like you aren’t exhausting memory on upload. You are exhausting it on page load. How big are you images (in kilobytes or megabytes)?

    I tryed upload only one 2MB picture and “the same story” ;/ I have got under 400MB free space on my hosting.

    400MB of what? Hard drive space or RAM?

    400MB of drive space of course.

    Not “of course”. I have 1.5Gb RAM on one of my servers, with somewhere between 70Mb and 700Mb available depending on load.

    Your problem is not hard drive space. It is RAM. You are running out of RAM.

    upload_max_filesize and post_max_size won’t help you. Your problem is with displaying the page not with uploading the image, as per your first post. You need to increase PHP’s general memory limit.

    Of course, you have to have the physical (or virtualized) RAM available in order to assign it. I don’t know how much RAM you have.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal error – wrong settings’ is closed to new replies.