Support » Fixing WordPress » Fatal error: Allowed memory size of 67108864 bytes exhausted Won't upload images

  • Resolved littlecuriosity

    (@littlecuriosity)


    Hi Clever WordPressers,
    I’ve got this fatal error in WordPress. It worked until a few days ago, This happened when I updated the network and my wordpress multi user install? It only does it on the main site, as it works fine on the sub sites.

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 4890018 bytes) in /home/artygirl/public_html/wp-includes/media.php on line 258

    It can’t be the memory limit as I fixed that ages ago.

    Thanks for all your help

    Regards
    Judi

Viewing 6 replies - 1 through 6 (of 6 total)
  • It still might be. I’ve changed my php.ini and that was sometimes enough but depending on the host I’ve had to put:

    define(‘WP_MEMORY_LIMIT’, ‘128M’);

    in the config file.

    Andrew is right, I’ve had to add define('WP_MEMORY_LIMIT', '128M'); to my wp-config.php before to solve that same problem.

    Thanks but I already have this.
    There are also different settings for file sizes in WPMU which I’ve figured out in the network options menu.

    Thanks for your help

    Hi Little Curiosity. Did you have any luck in solving this problem? I have the same problem and I have already defined the memory limit in the php.ini and also the wp-admin.php file.

    Any further ideas?

    Nicole

    In media.php file, there is hardcoded memory_limit for 256M. There is also a little description =”set artificially high as due to some GD component”. Well, after 2 hours in php.ini and other config files I have finally found that stupid hardcoded limit that was limiting my 140MB WXR file import.

    I had this same error and finally figured out the dimensions were too large on my images (they were over 2000 pixels). Even though the file sizes were small, this error was thrown.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal error: Allowed memory size of 67108864 bytes exhausted Won't upload images’ is closed to new replies.