Support » Plugin: WP Activity Log » Fatal Error with WP Security Audit Log

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Contributor robertabela

    (@robert681)

    Sorry to hear you are encountering this issue @sgb02

    Can you please:

    1) Give us a bit more detailed about your setup? From what I can see you are using usersWP, and our plugin is conflicting with it (or vice versa). So can you tell us:

    – if you have customized the login page
    – how is the usersWP plugin implemented (any particular settings etc)

    2) What version of our plugin are you using?

    3) What version of WordPress and PHP are you using?

    4) Can you give us more details on how to reproduce this issue? Is this error being generated whenever someone accesses the page, or when someone tries to login?

    5) Is the error a show stopper (i.e. the website crashes / user cannot work) or it is just generated in the background?

    The more details you can give us the quicker we can assist you. Looking forward to hearing from you.

    The plugin blocks themes after the last update

    1) I’ll get back to you on this question
    – if you have customized the login page
    – how is the usersWP plugin implemented (any particular settings etc)

    2) What version of our plugin are you using? – 3.4.3.1

    3) What version of WordPress and PHP are you using? WP 5.2.2, PHP 7.2

    4) Can you give us more details on how to reproduce this issue? Is this error being generated whenever someone accesses the page, or when someone tries to login? To recreate:
    – have WP Security Audit disabled, access website home page – works fine
    – activate WP Security Audit plugin
    – goto [server]/wp-login.php OR [server]/wp-admin – fatal error

    5) Is the error a show stopper (i.e. the website crashes / user cannot work) or it is just generated in the background? – Near Showstopper, fatal error if WP Security Audit is activated – Cannot login. So, we have disabled WP Security Audit plugin.

    UsersWP version 1.1.3

    Note we had both WP Security Audit ver 3.4.2 and UsersWP ver 1.1.3 running just fine for a couple weeks, then updated the WP Sec Audit plugin on Aug 30 and saw Fatal Error on Aug 31.

    I just confirmed that I can recreate the fatal error on a new WP 5.2.2, PHP 7.2 site with one sample page using theme 2019, and only 2 plugins installed : WP Security Audit Log ver 3.4.3.1, and UsersWP ver 1.1.3.

    To recreate:
    – activate UserWP plugin
    – have WP Security Audit disabled, access website home page – works fine
    – activate WP Security Audit plugin
    – goto [server]/wp-login.php OR [server]/wp-admin – fatal error

    To clear the fatal error, use FTP or similar app to rename the WP Security Audit Log plugin folder

    Plugin Contributor robertabela

    (@robert681)

    Hello @sgb02

    We have looked into the issue and this is what is happening:

    – Our plugin is using a function called wp_login_url to get the URL of the login page. We do this to verify if the current page is the login page or not.

    – The UsersWP plugin is using a filter hook in the above-mentioned function to change the URL of the login page.

    – In this hook, it is calling the function get_permalink a little earlier than expected.

    So as such, the issue / conflict here is being caused by UsersWP plugin not ours. So I would recommend you post this issue on their forum. Hopefully they will issue a fix. We are more than happy to work with them as well should they wish.

    I encountered this same php Fatal Error on my WPMU site when loading any page.

    Fatal error: Uncaught Error: Call to a member function get_page_permastruct() on null in /var/www/redacted.example.com/htdocs/wp-includes/link-template.php:373
    Stack trace:
    #0 /var/www/redacted.example.com/htdocs/wp-includes/link-template.php(335): _get_page_link(Object(WP_Post), false, false)
    #1 /var/www/redacted.example.com/htdocs/wp-includes/link-template.php(146): get_page_link(Object(WP_Post), false, false)
    #2 /var/www/redacted.example.com/htdocs/wp-content/mu-plugins/includes/class-theme-my-login.php(954): get_permalink(Object(WP_Post))
    #3 /var/www/redacted.example.com/htdocs/wp-content/mu-plugins/includes/class-theme-my-login.php(690): Theme_My_Login::get_page_link('login', Array)
    #4 /var/www/redacted.example.com/htdocs/wp-includes/class-wp-hook.php(288): Theme_My_Login->site_url('https://redacted...', 'wp-login.php', 'login')
    #5 /var/www/redacted.example.com/htdocs/wp-includes/plugin.php(208): WP_Hook->apply_filters('https://redacted...', Array)
    #6 /var/www/redacted.example.com/htdocs/wp-includes/link-template.php(3190): apply_filters('sit in /var/www/redacted.example.com/htdocs/wp-includes/link-template.php on line 373
    Error: The site is experiencing technical difficulties.

    fixed it by network deactivating the security-audit-log plugin
    (using wp-cli) wp plugin deactivate wp-security-audit-log --skip-plugins --network

    FWIW, we do use a handful of other plugins (some original), but we don’t use UsersWP. I suspect as seen in the stack trace that the ‘theme-my-login’ plugin might be the incompatible plugin in my case.

    reverting to the previous release of WP Security Audit Log also fixes my issue.
    wp plugin install --version=3.4.2 wp-security-audit-log --skip-plugins

    • This reply was modified 1 year, 4 months ago by tmuka.
    • This reply was modified 1 year, 4 months ago by tmuka. Reason: added details
    • This reply was modified 1 year, 4 months ago by tmuka. Reason: mention installed previous version as a workaround
    • This reply was modified 1 year, 4 months ago by tmuka.

    Having the same issue, suddenly:

    Fatal error: Call to a member function get_page_permastruct() on null in /home/topiqq60/public_html/websitename/wp-includes/link-template.php

    Disabling the plugin helps!

    Plugin Contributor robertabela

    (@robert681)

    Thank you everyone for the feedback. There is clearly a breaking change between 3.4.2 and 3.4.3. We are looking into it and will get back to you.

    Thank you for your cooperation and patience.

    Hi @robert681 I also got a fatal error wp message. It said the error was found on the page /wp-admin/admin-ajax.php?_fs_blog_admin=true.

    According to a cursory search, WP’s general support mods associate this page with your plugin: https://wordpress.org/support/topic/what-does-this-do-_fs_blog_admintrue/.

    Looks like a conflict with WooCommerce:

    An error of type E_COMPILE_ERROR caused by line number 152 of the public_html/wp-content/plugins/woocommerce/includes/blocks/class-wc-block-library.php. Error: require_once (): Failed opening required ‘public_html/wp-content/plugins/woocommerce/includes/blocks/class-wc-block-featured-product.php ‘ (include_path = ‘. / usr / share / php’)

    Plugin Contributor robertabela

    (@robert681)

    @yourcontenteditor the issue reported in this thread, the issue you are reporting and the issue you referred to are totally different things. Please open your own support thread.

    Plugin Contributor robertabela

    (@robert681)

    Hello @sgb02 @adalist @tmuka @1bjk903

    Can you please confirm if you all are using custom login pages? It seems there is an issue with that on our plugin, which we are looking into. Though would like a confirmation from your end.

    Looking forward to hearing from you.

    Yes @robert681 we are using custom login pages via the Theme My Login plugin with WP MU. Thank you for the great communication about this!

    Yes, We are using the UsersWP plugin which includes a custom login page.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Fatal Error with WP Security Audit Log’ is closed to new replies.