Support » Plugin: Kocuj Sitemap » Fatal Error with WP 4.7.3

  • I have updated my site to 4.7.3. After that i have updated your plugin also ( my current version is version 2.3.5) . But this problem has been occurred. And i cannot use admin dashboard anymore.

    ( ! ) Fatal error: Uncaught exception ‘KocujIL\V9a\Classes\Exception’ with message ‘[kocujilv9a] [component: all/options, code: 3, file: wp-content\plugins\kocuj-sitemap\libs\kocuj-internal-lib\classes\project\components\all\options\component.class.php, line: 287] Options container identifier already exists (options)’ in wp-content\plugins\kocuj-sitemap\libs\kocuj-internal-lib\classes\project\components\all\options\component.class.php on line 287
    ( ! ) KocujIL\V9a\Classes\Exception: [kocujilv9a] [component: all/options, code: 3, file: wp-content\plugins\kocuj-sitemap\libs\kocuj-internal-lib\classes\project\components\all\options\component.class.php, line: 287] Options container identifier already exists (options) in wp-content\plugins\kocuj-sitemap\libs\kocuj-internal-lib\classes\project\components\all\options\component.class.php on line 287

    Is there something wrong with my upgrade process ?

    • This topic was modified 7 months, 3 weeks ago by  andyle1710.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Dominik Kocuj

    (@domko)

    Unfortunatelly, your upgrade process has wrong order. There were some changes in WordPress that are incompatible with the functionality of Kocuj Sitemap plugin in versions older than 2.4.0. Because of that, when WordPress will be updated to 4.7.3, then the Kocuj Sitemap will be updated (in this order), the upgrade process for the Kocuj Sitemap plugin can work incorrectly. There can be no solution for this in the Kocuj Sitemap plugin, because it were changes in the WordPress core.

    The solution is to manually remove directory and all files for the Kocuj Sitemap plugin (“/wp-content/kocuj-sitemap”). Then you should login to your administration panel (it will work again) and reinstall WordPress in the newest version (in “updates” menu). Then you should copy manually the newest version of the Kocuj Sitemap plugin to “/wp-content/kocuj-sitemap” and check in “plugins” menu if it is activated (if not, activate this plugin). It should work now correctly.

    Please, let me know.

    I have follow your guide ( update WP 4.73, remove old Kocuj Sitemap plugin, install new Kocuj Sitemap plugin) but still meet error :

    ( ! ) Fatal error: Uncaught exception ‘KocujIL\V9a\Classes\Exception’ with message ‘[kocujilv9a] [component: all/options, code: 3, file: wp-content\plugins\kocuj-sitemap\libs\kocuj-internal-lib\classes\project\components\all\options\component.class.php, line: 287] Options container identifier already exists (options)’ in wp-content\plugins\kocuj-sitemap\libs\kocuj-internal-lib\classes\project\components\all\options\component.class.php on line 287

    ( ! ) KocujIL\V9a\Classes\Exception: [kocujilv9a] [component: all/options, code: 3, file: wp-content\plugins\kocuj-sitemap\libs\kocuj-internal-lib\classes\project\components\all\options\component.class.php, line: 287] Options container identifier already exists (options) in wp-content\plugins\kocuj-sitemap\libs\kocuj-internal-lib\classes\project\components\all\options\component.class.php on line 287

    Plugin Author Dominik Kocuj

    (@domko)

    That’s very strange, because I’ve tested the Kocuj Sitemap plugin and I’m personally using it on few websites with WordPress in the newest version.

    I’m not sure right now how can I help. I will see the code and try to find some things which maybe are responsible for this sort of problems on your website. I’ll let know in this topic.

    Plugin Author Dominik Kocuj

    (@domko)

    I’m checking code right now and I can’t see anything which would execute adding options container more than once and there is no reason to having this sort of error.

    I will be checking more, but for now I’d like to ask you if you have no other copies of the Kocuj Sitemap plugin on your website. Please, check if in your “wp-content/plugins” folder there are no more than one directory which contains text “kocuj”. It is important to know it for me, if I want to help you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fatal Error with WP 4.7.3’ is closed to new replies.