Support » Plugin: WooCommerce Pay for Payment » Fatal error with woocommerce 3.0.9

  • Resolved pattihis

    (@pattihis)


    I updated woocommerce to new version 3.0.9 and admin panel shows white screen. I turned on” Debug” in wp-config and it showed me the following error:

    Fatal error: Uncaught Error: Call to undefined function WC() in /var/www/vhosts/mydomain/httpdocs/wp-content/plugins/woocommerce-pay-for-payment/admin/class-pay4pay-admin.php:220 Stack trace: #0 /var/www/vhosts/mydomain/httpdocs/wp-includes/class-wp-hook.php(298): Pay4Pay_Admin->add_payment_options(”) #1 /var/www/vhosts/mydomain/httpdocs/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(NULL, Array) #2 /var/www/vhosts/mydomain/httpdocs/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #3 /var/www/vhosts/mydomain/httpdocs/wp-settings.php(469): do_action(‘wp_loaded’) #4 /var/www/vhosts/mydomain/httpdocs/wp-config.php(91): require_once(‘/var/www/vhosts…’) #5 /var/www/vhosts/mydomain/httpdocs/wp-load.php(37): require_once(‘/var/www/vhosts…’) #6 /var/www/vhosts/mydomain/httpdocs/wp-admin/admin.php(31): require_once(‘/var/www/vhosts…’) #7 /var/www/vhosts/mydomain/httpdocs/wp-admin/index.php(10): require_once(‘/var/www/vhosts…’) #8 {main} thrown in /var/www/vhosts/mydomain/httpdocs/wp-content/plugins/woocommerce-pay-for-payment/admin/class-pay4pay-admin.php on line 220

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Karolina Vyskocilova

    (@vyskoczilova)

    Hi @pattihis,
    I’m not able to reproduce the error. Are you sure, that you have WC properly installed and active? Is it multisite or normal install?

    I’ve added some WC check to the newest version of WooCommerce Pay for Payment at GitHub repo, could you please download it and try it again before I release it?

    https://github.com/vyskoczilova/woocommerce-payforpayment

    Hello,
    Yes I believe WC is properly installed and we are talking about a normal single site. Here’s some system info:

    ### WordPress Environment ###
    
    Home URL: 
    Site URL: 
    WC Version: 3.0.9
    Log Directory Writable: ✔
    WP Version: 4.8
    WP Multisite: –
    WP Memory Limit: 256 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: el
    
    ### Server Environment ###
    
    Server Info: nginx/1.11.1
    PHP Version: 7.0.19
    PHP Post Max Size: 16 MB
    PHP Time Limit: 120
    PHP Max Input Vars: 1000
    cURL Version: 7.29.0
    NSS/3.19.1 Basic ECC
    
    SUHOSIN Installed: –
    Max Upload Size: 16 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔
    
    ### Database ###
    
    WC Database Version: 3.0.9
    WC Database Prefix: 7Lr9nJr_
    woocommerce_sessions: ✔
    woocommerce_api_keys: ✔
    woocommerce_attribute_taxonomies: ✔
    woocommerce_downloadable_product_permissions: ✔
    woocommerce_order_items: ✔
    woocommerce_order_itemmeta: ✔
    woocommerce_tax_rates: ✔
    woocommerce_tax_rate_locations: ✔
    woocommerce_shipping_zones: ✔
    woocommerce_shipping_zone_locations: ✔
    woocommerce_shipping_zone_methods: ✔
    woocommerce_payment_tokens: ✔
    woocommerce_payment_tokenmeta: ✔
    MaxMind GeoIP Database: ✔
    
    ### Security ###
    
    Secure connection (HTTPS): ✔
    Hide errors from visitors: ✔
    
    ### Active Plugins (36) ###
    
    ### Settings ###
    
    API Enabled: ✔
    Force SSL: –
    Currency: EUR (€)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    Taxonomies: Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)

    I have downloaded your new version from github and installed it. Everything seems to be working fine now! Thank you very much for your time..!

    • This reply was modified 3 years, 3 months ago by pattihis.
    Plugin Author Karolina Vyskocilova

    (@vyskoczilova)

    Hi @pattihis,
    thanks a lot for the system info, everything seems ok. I’m still not quite sure what caused this problem, I’m glad to know that is solved. I will push the update officially soon. Still waiting because of WPML support is taking look on my plugin and when I push an update, the process starts again 🙁
    Cheers!
    Karolina

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fatal error with woocommerce 3.0.9’ is closed to new replies.