Support » Plugin: WooCommerce Stripe Payment Gateway » Fatal Error with WC 2.6.14

  • Hello,

    When using version 4.0.4 of this plugin with WooCommerce 2.6.14, a fatal error is triggered during the checkout process:

    PHP Fatal error:  Uncaught Error: Call to undefined method WC_Order::get_id() in wp-content/plugins/woocommerce-gateway-stripe/includes/compat/class-wc-stripe-compat.php:182
    Stack trace:
    #0 wp-includes/class-wp-hook.php(288): WC_Stripe_Compat->add_subscription_meta_data(Array, Object(WC_Order))
    #1 wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array)
    #2 wp-content/plugins/woocommerce-gateway-stripe/includes/abstracts/abstract-wc-stripe-payment-gateway.php(212): apply_filters('wc_stripe_payme...', Array, Object(WC_Order), Object(stdClass))
    #3 wp-content/plugins/woocommerce-gateway-stripe/includes/class-wc-gateway-stripe.php(675): WC_Stripe_Payment_Gateway->generate_payment_request(Object(WC_Order), Object(stdClass))
    #4 wp-content/plugins/woocommerce-gateway-stripe/includes/compat/class-wc-stripe-compat.php(166): WC_Gateway_Stripe->process_payment(276, true, true) in wp-content/plugins/woocommerce-gateway-stripe/includes/compat/class-wc-stripe-compat.php on line 182
    

    Since the plugin declares support for WC 2.6+, I wanted to bring this error to your attention. The older version of WC appears to access the id property directly, as there is no get_id() method.

    Thanks,
    Jeremy

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.