Support » Theme: Chaplin » Fatal error with theme

  • Resolved formidablefemme

    (@formidablefemme)


    Hi Anders,

    I just received an email from WordPress that there is a fatal error with the Chaplin theme. Here are the details: An error of type E_PARSE was caused in line 771 of the file /home2/ab14267/public_html/wp-content/themes/chaplin/functions.php. Error message: syntax error, unexpected ‘)’

    You can also see the error message when you visit my site, formidablefemme.com. I am unable to log in as it is affecting that page as well. Can you offer any insight? Thank you.

    Sarah

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Theme Author Anders Norén

    (@anlino)

    Hi @formidablefemme,

    This should be fixed in version 2.1.3, which just went live. It looks like the update has been installed on your site now. Really sorry for the issue occurring in the first place.

    — Anders

    Hi Anders,

    Thanks for your response! I’m still getting an error message on the site and can’t log in in one browser, but in the other browser it works. I wonder if that might have to do with cache/cookies, or waiting for the new version to roll out?

    Sarah

    Theme Author Anders Norén

    (@anlino)

    @formidablefemme That sounds like a cache issue. Give it another try in a bit.

    Hi again Anders,

    It still seems to have the error message, both for myself on the regular browser that I use, and for regular visitors to my site.

    I’m not sure what to do. Does the cache “recycle,” per se? Or will no one who has visited the site before be able to see it unless they clear their cache?

    Thanks,

    Sarah

    If it helps I just loaded your page for the first time and it loaded without any problems. If you’re using chrome hit ‘F12’ then right click on the reload icon and select “Empty Cache and Hard Reload”.

    Also, if you’ve created a child from the original chaplin theme make sure to increase/change the version number in you child’s style.css header. Some browsers will take this as a prompt to skip the cache and reload.

    Something to try. Good luck.

    Thanks, Greg! That is helpful to know you’re able to load my site. Thank you for the cache information, as well.

    I asked a number of people who have visited my site before and those who haven’t to see if they got the error message—most people did, even those who hadn’t visited the site before.

    I’m launching a big project on the site this week and need to be sure it’s up and running and accessible to everyone ASAP. Anders, is there anything else I can do? I know you said this was an issue with the theme and the updated version should have been good to go yesterday, but it still seems to be a widespread issue.

    If there’s anything I can do on my end, I’m happy to. Thank you, again.

    I have had the same problem updating to Jetpack 8.1. It could only be solved by getting back on my backup. As I see it, problems this kind continue so I am still with Jetpack 8.0 and I am therefore hesitating to update to Jetpack 8.1 again. Or am I wrong and Chaplin 2.1.3 is safe now?

    One more thing: I just received another email from WordPress that the error is persisting, and it says my site is running Chaplin 2.1.2, not 2.1.3. I also cannot access the theme via my site dashboard because it “failed to load properly.” Maybe this is an issue with my site not updating to the new theme?

    Theme Author Anders Norén

    (@anlino)

    @formidablefemme If you have FTP access to your server, you can go to the wp-content/themes folder and rename the chaplin folder. That will disable the theme and enable you to access the administration panel again. Activate a different theme, change the folder name back to chaplin, install the 2.1.3 version, and then activate the theme again. After that, you should be in the clear.

    @ivohuber Version 2.1.3 of Chaplin should be error free (it’s the one running on the demo site).

    Thank you, Anders. Once I change the folder name back, how do I install 2.1.3? Will it do so automatically?

    Theme Author Anders Norén

    (@anlino)

    @formidablefemme No problem! Sorry for the issues. You can find the updates page by going to Admin → Dashboard → Updates.

    Perfect. That did the trick! Thanks for all your help.

    Just experienced this on site where Chaplin used as parent theme. The Theme interface reported it broken with fatal error, with options at bottom to delete or resume (?) Neither did a thing. Manually deleting the theme via ftp and uploading a copy of 2.1.3 fixed it.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.