Support » Plugin: JVM Gutenberg Rich Text Icons » Fatal error with some versions of PHP

  • Resolved Rich Tape

    (@iamfriendly)


    Hi, thanks for creating this plugin. Unfortunately there’s an error on activation on some versions of PHP. Fortunately it’s a relatively simple fix.

    in init.php on line 110, there’s a comma at the end of the line. As this is the parameter list for a function call, some versions of PHP do not like that at all. Removing the comma, or adding the remaining default parameters will resolve this issue.

    wp_enqueue_style(
      'jvm-richhtext-icons-icon-font-css', // Handle.
      $fontCssFile, // <-- THIS COMMA HERE
    );

    If there is a github repo for this plugin I’d be happy to create a pull request for you to help resolve the issue.

    Thanks again!

Viewing 1 replies (of 1 total)
  • Plugin Author Joris van Montfort

    (@jorisvanmontfort)

    Thank you Richard for pointing that out. I have made a fix for this. I haven’t seen the error on my own websites so I had not noticed. Version 1.0.1 fixes this.

    Kind regards, Joris

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.