Support » Plugin: Site Reviews » Fatal error with site reviews and woocommerce

  • Resolved marcteller

    (@marcteller)


    Hello since the new update from woocommerce and the new uptdate from your plugin I have some problems on my website.

    All my woo commerce pages have caching problems with your plugin activated. And my woocommerce dashboard have lot of bugs.

    See the error I have below, seems to be an Abstract schema error:

    ‘Fatal error: Uncaught ArgumentCountError: Too few arguments to function Automattic\WooCommerce\StoreApi\Schemas\V1\AbstractSchema::__construct(), 1 passed in /home/customer/www/magicramp.com/public_html/fr/wp-content/plugins/site-reviews-woocommerce/plugin/Controllers/RestApiController.php on line 188 and exactly 2 expected in /home/customer/www/magicramp.com/public_html/fr/wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/StoreApi/Schemas/V1/AbstractSchema.php:47 Stack trace: #0 /home/customer/www/magicramp.com/public_html/fr/wp-content/plugins/site-reviews-woocommerce/plugin/Controllers/RestApiController.php(188): Automattic\WooCommerce\StoreApi\Schemas\V1\AbstractSchema->__construct(Object(Automattic\WooCommerce\StoreApi\Schemas\ExtendSchema)) #1 /home/customer/www/magicramp.com/public_html/fr/wp-content/plugins/site-reviews-woocommerce/plugin/Controllers/RestApiController.php(35): GeminiLabs\SiteReviews\Addon\Woocommerce\Controllers\RestApiController->modifyStoreEndpoint(Array) #2 /home/customer/www/magic in /home/customer/www/magicramp.com/public_html/fr/wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/StoreApi/Schemas/V1/AbstractSchema.php on line 47`

    Can you help me to fix please. All comments are really important for my commerce.

    Thank you

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Gemini Labs

    (@geminilabs)

    Yes, Woocommerce changed their Store API in v6.4.0 which broke the add-on integration.

    I have almost fixed it, but in the meantime you may want to downgrade Woocommerce back to v6.3.x

    Thread Starter marcteller

    (@marcteller)

    ok great thank you for your quick response 😉

    Plugin Author Gemini Labs

    (@geminilabs)

    Please update to Woocommerce Reviews v2.0.0 and let me know if the problem is fixed.

    Thread Starter marcteller

    (@marcteller)

    My dashboard now look ok but still have caching issues on my site, before it was only on page related to woocommerce now is in all my pages.

    my site reviews plugin is 5.23.5
    woocommerce reviews 2.0.0
    woocommerce 6.4.0

    Plugin Author Gemini Labs

    (@geminilabs)

    What kind of caching issues? Can you please send me more details of the problem using your Nifty Plugins account.

    Thread Starter marcteller

    (@marcteller)

    I have 2 menus setup (mobile and desktop).

    When site reviews is activated the 2 menus are showing on desktop, color and police are default aswell. When I deactivate the plugin everything work fine. I have turn off my modem, clean all my caches but only when I deactivate the plugin all come back normal.

    Plugin Author Gemini Labs

    (@geminilabs)

    Have you tried the troubleshooting steps on the Help page?

    Thread Starter marcteller

    (@marcteller)

    Just have done the troubleshooting. But didn’t resolved. I have made an update of all my pages and now it work fine.

    Thank you for your quick solution 😉 Have a good night or day

    Plugin Author Gemini Labs

    (@geminilabs)

    Sounds like it was a caching issue then. Glad it’s solved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Fatal error with site reviews and woocommerce’ is closed to new replies.