Support » Plugin: The Events Calendar » Fatal error with most recent update

  • Resolved 2mooses

    (@2mooses)


    Updated to the most recent version and started getting “critical error on this website” message on events. Also could not edit events, but can see the event archive pages of past events. Sometimes can’t get to a single event, as it’s really slow, and may eventually produce a 500 internal server error.
    Server error log reports:
    PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 1052672 bytes) in … /wp-content/plugins/the-events-calendar/common/vendor/lucatume/di52/src/tad/DI52/Container.php on line 247
    Everything else is running fine.
    Any help appreciated. Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter 2mooses

    (@2mooses)

    Also can’t publish new events. I get a “Publishing failed. The response is not a valid JSON response.” error.

    Plugin Contributor GeoffBel

    (@geoffbel)

    Hey @2mooses

    Thank you for reaching out.
    Yikes! That’s definitely not intended behavior.

    The first thing I would recommend is attempting to downgrade to a previous version of the plugin: https://theeventscalendar.com/knowledgebase/k/accessing-older-plugin-versions/

    Secondly, I would recommend checking your installation for a couple of things:

    1. Are you using a fairly recent version of PHP? Ideally 7.4 and up as per WordPress’ recommendations
    2. Are you using a fairly recent version of WordPress? Ideally 5.6 and up
    3. What does your PHP memory settings look like? Typically 128MB or higher is a good starting point

    If you are unsure where to find that info, head over to Events > Troubleshooting in wp-admin (/wp-admin/edit.php?post_type=tribe_events&page=tec-troubleshooting) and look for the system information section.

    Last but not least, it’s a good idea to test for conflicts (preferably on a staging clone of your site): https://theeventscalendar.com/knowledgebase/k/testing-for-conflicts/

    Let us know how that goes!
    Geoff

    matthewnie

    (@matthewnie)

    I also ran into the same or similar issue. Had to revert to 5.11.0 to have a usable site again.

    Thread Starter 2mooses

    (@2mooses)

    Thanks @geoffbel
    WordPress version is 5.8.2
    PHP is 7.4.25
    PHP memory is 512M
    I tried disabling all plugins.
    I also temporarily borrowed a pro license from another site and installed that.
    No luck. Same errors in the log.
    Have reverted to previous version 5.11.0 and everything seems ok again.

    Plugin Contributor GeoffBel

    (@geoffbel)

    Hey there @2mooses and @matthewnie

    Thank you so much for adding additional info to the mix.
    We think that we found the cause of the issue (although we have not been able to reproduce it on our end just yet).

    If one of you wouldn’t mind testing a fix, ideally on a staging site (so that your live site is not impacted), that would be awesome.

    The fix is to simply add the following filter to your site.
    add_filter( 'tec_views_v2_use_subscribe_links', '__return_false' );

    This can be done either via your child themes functions.php file OR by using the following plugin.

    Let me know if that fixes the issue.

    We really appreciate your collaboration.
    Geoff

    ssvtom

    (@ssvtom)

    @geoffbel Your fix does not solve it at our site.

    Tom

    Plugin Contributor GeoffBel

    (@geoffbel)

    Thank you so much @ssvtom

    Back to the drawing board.

    Stay tuned!
    Geoff

    I just experienced this error after the update to 5.12. I can see the monthly calendar, but if I click any event to see the details, after quite a delay I’m taken to a page that displays the event title along with the message:
    “There has been a critical error on this website.
    Learn more about troubleshooting WordPress.”

    The menu bar and header graphic are also out of wack.

    From what I can tell it only appears on the desktop version. The mobile version still seems to work properly.
    Noticed that cpanel was reporting cpu usage at 99%

    • This reply was modified 7 months, 3 weeks ago by prondeau.
    LS

    (@lsterling03)

    Confirming I have the same issue. Updated to 5.12 and event pages will not load — a long long delay and then finally a 502 error. Reverting back to 5.11 fixed it. I did not see any errors in the error log.

    Plugin Author Gustavo Bordoni

    (@bordoni)

    Hi Everyone,

    We have a fix for this problem that will come out on a release Early next week.

    My expectation is Monday or Tuesday at the latest.

    Best Regards,

    Plugin Support Deblyn Prado

    (@deblynprado)

    Hello there @2mooses @lsterling03 @prondeau @ssvtom and @matthewnie !

    We just released v5.12.2 that should fix the issue that you’re facing.

    Please update and let us know any feedback that you may have.

    Cheers,

    Thread Starter 2mooses

    (@2mooses)

    Thanks @deblynprado
    Just updated now, and that seems to have done the trick. No new errors.

    • This reply was modified 7 months, 2 weeks ago by 2mooses.

    Yes, can confirm, solved the issue for me as well

    Thanks!

    Plugin Support iammarta

    (@iammarta)

    Great to hear! We’re going to go ahead and mark it Resolved. Please feel free to open a new thread if any other questions come up and we’d be happy to help.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Fatal error with most recent update’ is closed to new replies.