Support » Plugin: Redis Object Cache » Fatal Error with 2.0.2

  • Resolved bestfrenchmortgage

    (@bestfrenchmortgage)


    I’ve just upgraded to 2.0.2 and get this error message
    Error Details
    =============
    An error of type E_ERROR was caused in line 236 of the file /home/davidjromano/public_html/wp-content/plugins/redis-cache/includes/class-plugin.php. Error message: Uncaught RedisException: Redis server went away in /home/davidjromano/public_html/wp-content/plugins/redis-cache/includes/class-plugin.php:236
    Stack trace:
    #0 /home/davidjromano/public_html/wp-content/plugins/redis-cache/includes/class-plugin.php(236): Redis->zRangeByScore(‘sdf:redis-cache…’, 1594708992, 1594710732, Array)
    #1 /home/davidjromano/public_html/wp-includes/class-wp-hook.php(287): Rhubarb\RedisCache\Plugin->enqueue_redis_metrics(‘settings_page_r…’)
    #2 /home/davidjromano/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #3 /home/davidjromano/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #4 /home/davidjromano/public_html/wp-admin/admin-header.php(104): do_action(‘admin_enqueue_s…’, ‘settings_page_r…’)
    #5 /home/davidjromano/public_html/wp-admin/admin.php(234): require_once(‘/home/davidjrom…’)
    #6 /home/davidjromano/public_html/wp-admin/options-general.php(10): require_once(‘/home/davidjrom…’)
    #7 {main}
    thrown

Viewing 6 replies - 1 through 6 (of 6 total)
  • From Redis Diagnostics screen (plugin disabled to avoid fatal error)

    Status: Disabled
    Client:
    Drop-in: Invalid
    Disabled: No
    Redis Extension: 5.2.2
    Predis Client: Not found
    PHP Version: 7.4.7
    Redis Version: Unknown
    Multisite: No
    Drop-ins:
    – advanced-cache.php v by
    – maintenance.php v by

    Thanks for reporting this error. I have informed tillkruss about the error – my guess would be that it will be fixed in version 2.0.3.

    In the mean time you can set WP_REDIS_DISABLE_METRICS to true to avoid this error. The core functionality will not be affected by this.

    Thanks, Is this to be added in redis-cache.php?

    Add the following to your wp-config.php:

    define( 'WP_REDIS_DISABLE_METRICS', true );

    Will reply to this topic after the bug has been fixed so you may remove the code again.

    Many thanks, this works

    Plugin Author Till Krüss

    (@tillkruess)

    Hi @bestfrenchmortgage.

    This was fixed in c8d58ce and I’ll release 2.0.3 shortly.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.