Support » Fixing WordPress » Fatal error while updating WP…

  • So I was updating WP from the panel and at the end of the proccess I got fatal errorr. It looked like this:

    Unpacking actualisations…
    Verification of files…
    Preparing to install the latest version…
    Turning on maintenance mode…
    Copying the required files…
    Turning on maintenance mode…
    Updating the database…

    Fatal error: Maximum execution time of 5 seconds exceeded in /profiles/f/fu/fun/BLABLABLA/wp-admin/includes/class-wp-filesystem-direct.php on line 222

    But thing is everything seems to be working fine. Wp updated. Should I be worried about this?

Viewing 5 replies - 1 through 5 (of 5 total)
  • You need to increase your server timeout duration (ask your host provider to do that). then from updates page try to re-install WordPress just to be sure that everything is fine.

    Im using free website hosting so Im afraid asking them to increase server timeout will not be an option. But I have actually read I can change that timeout limitation myself in .htaccess file?

    Try it and let us know if it works :p

    Well, seems there is no such file on my ftp folder. There is only .htgroup and .htpasswd. I guess if there will be no problems I will just leave this as it is.

    Moderator t-p

    (@t-p)

    Im using free website hosting so Im afraid asking them to increase server timeout will not be an option.

    WordPress does function well on free web hostings.

    Consider finding a good host. Useful Guide: https://wordpress.org/hosting/

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal error while updating WP…’ is closed to new replies.