Support » Installing WordPress » Fatal error when using automatic update

  • Resolved slappyman

    (@slappyman)


    I get this error after auto update to I think version 3.1.4 Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 77824 bytes) in /home/slappys/public_html/wp-admin/admin-header.php on line 118
    I also get the same error but line 78.
    I can access my site just fine but no joy with dashboard New to this any help would be great, thank you

Viewing 15 replies - 1 through 15 (of 18 total)
  • Wow, that’s a first. Never seen an install with the memory limit set to 256K.

    Ask your host how to increase the memory limit. We recommend increasing it to at least 64M.

    I have enough memory but while updating to 3.2, I got the same error. Till today everything was fine.

    Also got below error:
    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 68 bytes) in /home/ssinghai/public_html/wp-content/themes/suffusion/functions.php on line 1466

    Memory size is not problem at my end.

    Also please tell me this is the forth update which has resultant as crash. Why your automatic update never works.

    only?

    my fault I’m in everything, every time I go I notice errors in different site, enter it, and I’ve solved one, but the 3 o4 4 more failures I have not been

    Fatal error: Out of memory (allocated 31981568) (tried to allocate 40 bytes) in /homepages/41/d358764671/htdocs/wordpress/wp-includes/cache.php on line 429

    and

    /wp-admin/admin-header.php on line 99

    and more uff

    Fatal error: Out of memory (allocated 31981568) (tried to allocate 77824 bytes) in /homepages/41/d358764671/htdocs/wordpress/wp-admin/menu-header.php on line 99

    and this muaaaaaaaaaaa

    How can one downgrade a version, rather than upgrade?

    WordPress 3.2 has caused a fatal error with my website’s theme: perhaps if I restore the site with WordPress 3.1, the site will be restored to normal function?

    I attempted to go back to 3.1 and it was there but did not work right anymore. Found my original problem was with web host not running correct version of PHP, they are updating now. So we’ll see what happens.

    This issue is caused by unsuccessful update from WordPress 3.1 to 3.2.x. WordPress 3.1 does not define MAX_MEMORY_LIMIT on “includes/default-constants.php”. which is being called on wordpress 3.2’s admin.php

    error_log message: PHP Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 1853353 bytes) in….

    resolution: manually update the file by downloading the latest copy of wordpress and replace the includes folder.

    Notes: Before uploading “include” folder of the new version:

    1. Rename your existing “include” folder to something else as a backup (e.g. include_bak)
    2. Create a backup of your database:
    mysqldump [databasename] -u[database_username] -p[db_user_password] > backupfilename.sql

    After making the necessary backups, login on your admin panel. WordPress will now prompt to update your database after this fix so make sure you created a backup before proceeding.

    You should be able to login on your admin panel after the database update.

    THANK YOU cedar818!! I searched this forum for hours and tried all the other “fixes” but nothing worked. Your suggestion did the trick. THANK YOU!!!

    You’re very welcome varnerific 🙂 Glad I was able to help.

    For anyone else with this problem, the person posting the fix wasn’t very clear on what folder needs to be re-uploaded. The poster mentions the folder “include” a couple of times, which does not exist. It is the /wp-includes folder that needs it.

    I hope this clarification helps others.

    I hope someone can help. This is turning out to be a real train wreck 🙁

    This was the original error after automatic upgrade attempt:
    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 77824 bytes) in /home/xyz/public_html/wp-admin/includes/dashboard.php on line 623

    ~~~~~~~~~~~~~~~~

    I replaced the wp-includes directory as suggested, and now the blog home page doesn’t appear. (So I can’t login to admin either of course) I get the following error:

    Warning: require(/home/xyz/public_html/wp-includes/classes.php) [function.require]: failed to open stream: No such file or directory in /home/xyz/public_html/wp-settings.php on line 68

    Fatal error: require() [function.require]: Failed opening required ‘/home/xyz/public_html/wp-includes/classes.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/aptdocto/public_html/wp-settings.php on line 68

    Any ideas?

    The error is telling you that you have a missing file. /home/xyz/public_html/wp-includes/classes.php apparently does not exist. Can you log in, either via cPanel’s file manager, or through FTP, and see if that is the case?

    In response to sneader (thank you)….

    Yes, I checked via FTP and this particular file is missing. There is no “classes.php” in the fresh download of the wp-includes directory (and therefore no classes.php on the server)

    I tried just replacing this specific file: includes/default-constants.php

    …so now the home page has returned, but I get this error when trying to login to the dashboard. No matter what I do, I can’t seem to get the dashboard back.

    Fatal error: Call to undefined function is_network_admin() in /home/xyz/public_html/wp-admin/admin-header.php on line 24

    did you make a backup of your database and the old wp-include folder before making the changes?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Fatal error when using automatic update’ is closed to new replies.