WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Fatal error when uploading images

[Resolved] Fatal error when uploading images

  • Hello,
    I have recently upgraded to 2.3 from 2.2. I am getting a strange error for which I have not found anything of help online:

    “Fatal error: Cannot use object of type WP_Error as array in /home/public_html/wp/wp-includes/taxonomy.php on line 1010”

    I have tried removing several plugins, reinstalling… nothing
    Any ideas where to start resolving this problem?

Viewing 8 replies - 1 through 8 (of 8 total)
  • This is the only reference to that error in the forum:
    http://wordpress.org/support/topic/135958?replies=2

    I too have this error
    solutions??????????

    Not using any plug ins all deactivated

    ok..I fixed the problem. The problem was that I switched server so the image paths were not being read correctly.
    To get it to work again I erased everyting and did the following:
    1. I did a fresh install of wordpress and made sure that the image upload worked without errors on my first post.
    2. I ran an automatic subtituion of the previous server path with the new correct server path in my sql file.
    3. I imported the sql file with the substitutions.
    everyhing works fine.

    I didn’t switch server, but also am getting this error.

    Is there any other support than erasing everything and doing a fresh install?

    I get this also – for image uploads & page & post saves. After a fresh install & new DB, I now only get it when trying to upload images.

    This seems to be a *huge* issue with only a hit or miss solution.

    A huge issue is this forum that is very difficult to search and keep messages as a thread… there are now about 5 separate posts regarding this issue

    “Fatal error: Cannot use object of type WP_Error as array in /home/public_html/wp/wp-includes/taxonomy.php on line 1010”

    and no answers yet…. this post should not have been marked resolved – and it is probably being overlooked by the smart ones who can help;)

    sorry, you are right. for me this is resolved

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Fatal error when uploading images’ is closed to new replies.
Skip to toolbar