Support » Theme: Neve » Fatal error when upgrading to PHP8

  • Resolved Per Olsson

    (@styrketrappan)


    Hi,

    When upgrading to PHP8 I get the following fatal error:
    Parse error: syntax error, unexpected token “\” in /home/xxxxxx/public_html/wp-content/themes/neve/inc/compatibility/amp.php on line 44

    Something in the Neve theme or something else? I am not so into technology 🙂

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,

    Unfortunately, that’s a small bug in Neve which can cause that error in few cases. We will release an update for it, most likely next week, but until then, what you can do is contact your hosting provider and ask them to make this small change in your Neve theme:

    in inc > compatibility > amp.php

    remove \ from the end of this line:

    add_filter( 'walker_nav_menu_start_el', array( $this, 'wrap_content' ), 10, 4 );\

    Hi,

    We’ve also released an update for this, so everything should be alright in the latest update.

    Regards

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Fatal error when upgrading to PHP8’ is closed to new replies.