WordPress.org

Support

Support » Installation » Fatal error when upgrading from 2.3.3 to 2.5 by Fantastico

Fatal error when upgrading from 2.3.3 to 2.5 by Fantastico

  • I upgarded my 2.3.3 by Fantastico to 2.5 by now I can see only a blank page with this error:

    Fatal error: Cannot unset string offsets in /home/emoir/public_html/shahne.com/weblog/wp-includes/widgets.php on line 315
    Can anyone help me?

Viewing 5 replies - 1 through 5 (of 5 total)
  • It looks like it’s working now… you must’ve solved the problem!

    Edited to add that I looked at the blog in your profile, which is working. I see now that the http://www.shahne.com/webglog site is the one you’re having difficulties with.

    I found these threads, one of which may supply a solution for you:

    http://wordpress.org/support/topic/164836
    http://wordpress.org/support/topic/126759
    http://wordpress.org/support/topic/165484

    Thanks,But i have the problem now. I saw these links before, but my problem is different from them.

    Has this been solved yet?

    I also looked at those links and the solution was for a “dashboard” problem. Not quite the same as the “widgets” one.

    I had the same problem – except I didn’t upgrade. I was on 2.3.3, then all of a sudden, 20 hours ago, it just konked out and I got the same error log from widgets.php line 315.

    So then I tried upgrading files to 2.5.1 but that didn’t change much. Still no access to the webpage. Then my error_log file got too big (45 megs) so I couldn’t check the error anymore.

    Unfortunate part is, it just happened with no changes from myself. Analytics showed people accessed my site around 04:00 (GMT) then at 06:00 (GMT) when I woke up and went to update blog, I got a blank page.

    Any help would be much appreciated, I’m in process of uploading an old backup – see how that goes.

    I got my site back up and working!

    I went through all the above forums/threads and none of them applied to me. I tried them, just didn’t solve my issue.

    I’ve semi-documented my issue on my own site here

    Chiefly, I think it’s down to creating a new user for your MySQL database.

    One thing that puzzles me saeed, how did you manage to upgrade your 2.3.3 to 2.5 with Fantastico? I could not do that, and had to delete my existing wordpress installation.

    soylent

    @soylent

    This has to do with magic_quotes_runtime being turned on in your php configuration. I did this on my local server and it immediately gave me the error. Turned it off, error went away.

    If your host turned this on, you may be able to override it with ini_set(). I found this information at the following post:
    http://wordpress.org/support/topic/155986?replies=3#post-690693

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fatal error when upgrading from 2.3.3 to 2.5 by Fantastico’ is closed to new replies.
Skip to toolbar