Support » Plugin: BackWPup - WordPress Backup Plugin » fatal error when updating..about an hour ago

  • Resolved psnyder


    I got a fatal error message when updating the backwpup plugin. This was about 8:30 am eastern time on May 3.

    Here’s the messsge: Fatal error: Call to undefined method stdClass::add_role() in /home/birdie/public_html/wp-content/plugins/backwpup/inc/class-install.php on line 94

    I have never had this happen before and quite frustrated. Does this mean I have lost all my work? What do I do now? I have no idea how to fix this problem. I can’t log on or anything.

    The only thing I know to do is to ask here and to contact my hosting.

    Any help is greatly appreciated.

    Thank you,

Viewing 9 replies - 1 through 9 (of 9 total)
  • Caspar


    Hi psnyder,

    no worries, it just means our plugin had a hickup. Your site is still there and fine, but you say you can’t log in? Have you tried going to your login page? It usually is at http://your-domain.tld/wp-login.php (where your-domain.tld stands for your website address).

    Please try logging into your site first before we come back to the error message.

    Hi Casper,

    I tried to login to my wp admin .. and I get the same error message. This is how I log in. I have never logged in the way you are suggesting. So, I will type in

    Fatal error: Call to undefined method stdClass::add_role() in /home/birdie/public_html/wp-content/plugins/backwpup/inc/class-install.php on line 94

    I hope you are correct and that the site is still there… I have been physically sick thinking I’ve got to do this all over again..



    The site is still there. Do you have access to your web space via FTP?

    yes, I do, I am just not very good at the ftp thing. It confuses me for some reason. I use filezilla.



    Ok, please log in to your web space with FileZilla and go to the folder where your WordPress site resides. (The one that most likely has a file named wp-config.php in it.)
    From there go to wp-content -> plugins and rename the folder backwpup into backwpup-xx.
    BackWPup is now disabled and you can log in into your site via /wp-admin. You’ll see a notification that BackWPup has been disabled, because the plugin folder doesn’t exist. (That’s because we renamed it.)
    Once you’re logged in and your site is back up, please come back here and we’ll fix the rest.



    If you want to get BackWPup back up and running before we release the next update, you can replace the contents of backwpup-xx/inc/class-install.php with the contents of this pastebin:
    (Note the small icon at the top of the large text field. On Mouseover it says “Copy text to clipboard”)

    After replacing the contents of class-install.php, rename backwpup-xx into backwpup again and activate BackWPup in your WordPress backend.

    Hope this helps and your site is accessible again. Please don’t hesitate to post here if you need further assistance with BackWPup. I might be absent, but Robert is going to pitch in.

    Hi Caspar,

    Thanks for all your help. I got the plugin removed via http://ftp..

    When is your next update? The instructions sound a bit over my head 🙂

    I forgot to add that the site is now not displaying the footer and side bar is down at the bottom.. I don’t know if that has anything to do with the plugin or not.

    Here’s the site if you want to take a look:

    <a href=”

    Thank you in advance.



    Are you sure that sidebar issue happened only now, after the plugin error?
    I can see a CSS float being cleared where it probably shouldn’t, but it’s hard for me to see where exactly.

    BackWPup does absolutely not touch any of your theme’s CSS files, though, so I can’t think of any way this could be caused by the error we had. An fatal error does make your site impossible to access (which is uncomfortable enough), but it doesn’t change anything in your theme files.

    My best guess would be for you to go through your theme options, menus, widgets and check if any settings need to be changed.

    (I’m marking the topic as resolved since we git rid of that error.)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘fatal error when updating..about an hour ago’ is closed to new replies.