Support » Plugin: Jetpack by WordPress.com » Fatal Error when updating to Jetpack 4.0? Read this.

  • ResolvedPlugin Author Jeremy Herve

    (@jeherve)


    Jetpack Mechanic 🚀

    Update: You can now update to Jetpack 4.0.2 to fix this issue.

    It seems that in some cases, the latest version of Jetpack (4.0) is causing PHP fatal errors and/or white screens when you upgrade to it. We’re tracking this problem on GitHub here:

    https://github.com/Automattic/jetpack/issues/3697

    Until we fix the issue and release a new version of Jetpack, you can recover by manually removing the Jetpack plugin. If you don’t have access to your site’s Dashboard due the the white screen, you can delete the folder wp-content/plugins/jetpack using an FTP client like Cyberduck:

    https://cyberduck.io/?l=en

    If you’re not sure how to do this, ask your hosting company for help.

    Some hosts also provide a hosting panel (like cPanel) that has a “File Manager” tool. This will also let you browse to the same folder and delete the “jetpack” directory.

    After that’s done, you can reinstall the version of Jetpack prior to 4.0, which is 3.9.6. You can download it here:

    https://downloads.wordpress.org/plugin/jetpack.3.9.6.zip

    3.9.6 will ask you to upgrade to 4.0, but just ignore that for now until the GitHub issue above is resolved.

    We’re also working on a new release to fix this problem as soon as possible.

    Sorry for all the trouble here!

  • The topic ‘Fatal Error when updating to Jetpack 4.0? Read this.’ is closed to new replies.