Support » Plugin: WooCommerce Multilingual - run WooCommerce with WPML » Fatal error when updating product visibility in quick edit

  • Resolved sue_c

    (@sue_c)


    2019-01-07T00:00:08+00:00 CRITICAL Uncaught Error: Call to undefined method WPML_Translation_Element_Factory::create_post() in /wp-content/plugins/woocommerce-multilingual/inc/class-wcml-attributes.php:720
    Stack trace:
    #0 /home/luckymer/public_html/wp-includes/class-wp-hook.php(288): WCML_Attributes->set_translation_status_as_needs_update(‘1256737’, 69420, ‘_product_attrib…’)
    #1 /public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array)
    #2 /public_html/wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #3 /public_html/wp-includes/meta.php(234): do_action(‘update_post_met…’, ‘1256737’, 69420, ‘_product_attrib…’, Array)
    #4 /public_html/wp-includes/post.php(1934): update_metadata(‘post’, 69420, ‘_product_attrib…’, ‘a:9:{s:19:”allo…’, ”)
    #5 /public_html/wp-content/plugins/woocommerce/includes/data-stores/class-wc-product-data-store-cpt.php(763): update_post_meta(69420, ‘_product_attrib…’, Array)
    #6 /public_html/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-attributes.php on line 720

    I’m running
    WPML Multilingual CMS Version 4.0.3
    WPML String Translation Version 2.8.3
    WPML Translation Management Version 2.6.3
    WooCommerce Multilingual Version 4.3.7

    I really need to get this fixed. I’ve already tried to get in touch with WPML but I haven’t heard back.

    Thanks again

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support George Botsev

    (@botzev)

    Hello and thank you for contacting us.
    I see that you are using quite an old WPML version and WPML addons versions…

    Please update to the latest version and I am pretty sure that the error will be resolved.

    Remember to create a backup before upgrading.

    I updated WPML and the error has not been resolved. I’m getting the same error. Not sure what to do now. I can’t set the visibility for products. We’re trying to hide simple products from the catalog because they’re part of a group.

    Plugin Support George Botsev

    (@botzev)

    That is very strange.
    You said that you have contacted us in our wpml.org forum?
    Can you direct me to the ticket link?

    I feel that I need to take a closer look and check what happens, as I cannot reproduce a similar error in my testing setup.

    I have the same error with this plugin. I don’t have more information to bring though.

    I managed to fix the error. Turned out if was related to In Stock. When bulk editing products make sure that all options are set to No Change except visibilty. For some reason when some products were in stock and others out of stock, the option was set to In Stock which caused the issue.

    I did some checks and our problems started the very day we updated from 4.3.6 to 4.3.7.

    Even if you “solved” your issue by fixing your code, the plugin can still trigger a “Fatal error”. Our code had been working for months. At first sight, it seems linked to the attributes changed that were done.

    Plugin Support George Botsev

    (@botzev)

    Hello @maximejobin
    If you can provide more details on how to reproduce the problem, I would be happy to try it out and see if I can reproduce or suggest a fix.
    If you wish, you can open a ticket at our support forum at wpml org where you can share access details securely so that we can debug this issue and help you.

    Plugin Author Andreas Panag

    (@andrewp-2)

    Since we don’t have news for some time, I am closing this ticket.

    If you still have problem, please feel free to open a ticket in wpml.org so we can help you.

    Thank you very much

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.