Support » Fixing WordPress » Fatal error when trying to upgrade to 2.1

  • I get the following error when trying to run the upgrade script.

    Fatal error: Call to undefined function: add_filter() in /home/chrisleg/public_html/wp-includes/default-filters.php on line 4

    I’ve done multiple WP upgrades in the past and I’ve never had a problem. Any help is appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • add_filter() is a function in wp-includes/plugin.php. Do you have this file, is it *not* zero bytes in size, etc.?

    I would be concerned that not all of your files were installed/upgraded successfully.

    Thanks for the reply…

    My plugin.php file is 6kb in size.

    I’m going to try re-uploading all the files and see if that will straighten things out.

    **crosses fingers**

    I’ll edit this post once I’ve double checked everything…

    Edit: Everything seems to be working fine now.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Fatal error when trying to upgrade to 2.1’ is closed to new replies.