WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Fatal Error when setting up groups on step 2

[Resolved] Fatal Error when setting up groups on step 2

Viewing 13 replies - 1 through 13 (of 13 total)
  • crazywpgeek
    Member

    @crazywpgeek

    Hey I’m still having problems with this. Is there any support for this at all?

    Getting this error when creating a group on step 2 which is where this plugin is supposed to work.

    Fatal error: Using $this when not in object context in /home3/shonuff/public_html/networking/wp-content/plugins/bp-group-hierarchy/extension.php on line 122

    Using WP 3.5.2 and BuddyPress latest 1.7

    Plugin Author David Dean
    Member

    @ddean

    Hi crazywpgeek –

    Can you provide some details on your install, including other active plugins, and your BP setup? This is the first report of a problem like yours.

    – David

    crazywpgeek
    Member

    @crazywpgeek

    Hi David,

    Did you watch the video I posted above? Here is the link again: http://screencast.com/t/SS0Zpdv72v

    As you can see with the video I’m using BuddyPress 1.8 and only your plugin (near the end after I disabled everything else).

    Groups are activated with BuddyPress

    I’m using buddyboss theme (and actually doesn’t matter which theme because I tried the default theme for buddypress and its doing the same thing).

    wordpress 3.5.2

    Hi,

    I’m having same issue since update to BP 1.8.

    Since 1.8 rewrite the Group Extension API it was no surprise (nearly all plugins using groups broke) :
    http://codex.buddypress.org/developer/plugin-development/group-extension-api/

    As it was suggested on BP forums i switched back BP group files to 1.7 and everything goes back to normal for now.

    Thanks for your support and great extension !

    After a closer look my guess is the BP_Group_Extension is not anymore instanciated when calling screen function (at less).

    So only static access is usable, $this is not available.

    crazywpgeek
    Member

    @crazywpgeek

    @grima,

    Thank you for this. I’m wondering if David will issue an update for this. Is it possible to roll back to BP 1.7 ?

    Thanks

    Kevin

    Don’t know for a full rollback.

    I’ve just uploaded the 1.7 groups files overs 1.8 BP install, wich is dirty but do the trick waiting for patch.

    I followed this topic for the bbpress wich has quite the same problem i guess :

    Fatal Error: Unable to create forum from buddypress group

    Plugin Author David Dean
    Member

    @ddean

    Hi everybody –

    I am looking into this, but I am able to create groups without error on WP 3.5.2, BuddyPress 1.8 and Hierarchy 1.3.9. Step 2 presents no problems for me. If anyone can provide more specific details about what happens, that would speed up a resolution. For instance, do you have WP_DEBUG enabled? Are these new installs or upgrades?

    @crazywpgeek – your video (the whole site, really) does not load for me, so I haven’t been able to watch it. Can you provide any more details about specific circumstances?

    – David

    crazywpgeek
    Member

    @crazywpgeek

    Hi David,

    Sorry about the video not loading as that is where 99% of all the info about this error is. I put the .mp4 video in a zip file. Are you able to open zip files?

    You can download it from here: http://www.firstpagecoach.com/error.zip
    **I’m uploading it now so it will take a few minutes for it to completely upload. file should be just over 15mb total**

    the url to the site is flyppl.com/networking

    I’ll remove the password protection on it so you can see the site.

    In the wp-config.php debug mode is set to false.

    Using WordPress 3.5.2
    BuddyPress 1.8
    Hierachy 1.3.9

    I’ll go ahead and activate only the buddypress and the hierachy plugins.

    As far as the installation: The site is a month old, and this error is after first installing the plugin and trying to setup groups.

    Let me know if the video plays. In the video I go through some troubleshooting (one of things I did I accidentally deactivated buddypress but figured it out later), but still doesn’t work.

    Kevin

    I’ve just tried with BP 1.8.1 wich fix the problem.

    Here is the bug report matching :
    https://buddypress.trac.wordpress.org/ticket/5126

    Sorry for the report, it was a BP bug in the end.

    crazywpgeek
    Member

    @crazywpgeek

    Hi Grima,

    Thanks for posting this. So glad it got fixed. I will update to BP 1.8.1 and see what happens.

    Thanks

    Kevin

    Plugin Author David Dean
    Member

    @ddean

    Just came in to see whether this was ultimately caused by bug 5126. Looks like I’ll need to add different PHP versions to the test rig along with all the different WP versions. 🙂

    Thanks, everyone!

    crazywpgeek
    Member

    @crazywpgeek

    David,

    Appreciate the work you do. Just donated $10 to this plugin for your hard work. I know its not much, but hopefully this will help a little.

    Thanks

    Kevin

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Fatal Error when setting up groups on step 2’ is closed to new replies.