• Resolved David Borrink

    (@davidborrink)


    My client is using WooCommerce Memberships, and has a problem when trying to use the search feature on the posts back end. A fatal error is triggered. The error message says that WooCommerce Memberships is involved. Here is the error message:

    Fatal error: Uncaught TypeError: Illegal offset type in /nas/content/live/laurenhill/wp-content/plugins/woocommerce-memberships/src/admin/class-wc-memberships-admin.php:814 Stack trace: #0 /nas/content/live/laurenhill/wp-includes/class-wp-hook.php(324): WC_Memberships_Admin->display_restrictable_post_types_bulk_actions_notices(”) #1 /nas/content/live/laurenhill/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters(NULL, Array) #2 /nas/content/live/laurenhill/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #3 /nas/content/live/laurenhill/wp-admin/admin-header.php(303): do_action(‘admin_notices’) #4 /nas/content/live/laurenhill/wp-admin/edit.php(411): require_once(‘/nas/content/li…’) #5 {main} thrown in /nas/content/live/laurenhill/wp-content/plugins/woocommerce-memberships/src/admin/class-wc-memberships-admin.php on line 814

    and

    Error Details
    =============
    An error of type E_ERROR was caused in line 814 of the file /nas/content/live/laurenhill/wp-content/plugins/woocommerce-memberships/src/admin/class-wc-memberships-admin.php. Error message: Uncaught TypeError: Illegal offset type in /nas/content/live/laurenhill/wp-content/plugins/woocommerce-memberships/src/admin/class-wc-memberships-admin.php:814
    Stack trace:
    #0 /nas/content/live/laurenhill/wp-includes/class-wp-hook.php(324): WC_Memberships_Admin->display_restrictable_post_types_bulk_actions_notices(”)
    #1 /nas/content/live/laurenhill/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters(NULL, Array)
    #2 /nas/content/live/laurenhill/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
    #3 /nas/content/live/laurenhill/wp-admin/admin-header.php(303): do_action(‘admin_notices’)
    #4 /nas/content/live/laurenhill/wp-admin/edit.php(411): require_once(‘/nas/content/li…’)
    #5 {main}
      thrown

    I’m reporting this so that perhaps someone might be able to point to whether the plug-in needs an update or if this is on my client’s site. Thanks!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Shameem (woo-hc)

    (@shameemreza)

    Hi @davidborrink

    I understand that you are using the premium plugins WooCommerce Memberships here.

    Since this is related to a premium extension, please contact us directly here. You may need to create an account before you can access that page.

    As per the forum guidelines, no support for premium extensions is done here, but we will be happy to assist you further from there 🙂

    Thanks!

    Thread Starter David Borrink

    (@davidborrink)

    Shameem, thank you for your response. I went to the link you shared and when trying to choose Technical Support for WooCommerce Memberships, that plug-in is not listed in the choices of programs to request help for from the drop-down menu. I cannot make any choices for help. I need more assistance in order to start getting help.

    Plugin Support omarfpg (woo-hc)

    (@omarfpg)

    Hi @davidborrink,

    Thanks for the heads-up. I just tested this and I can confirm it’s not showing up when you select Technical Support. Please use the option for Presales for now, that should get you there!

    Thanks!
    -OP

    Thread Starter David Borrink

    (@davidborrink)

    Great. Thank you. I just submitted my question to that area. Thanks for helping me be able to get something posted over there.

    Plugin Support carolm29 (woo-hc)

    (@carolm29)

    hey, @davidborrink!

    I’m happy we were able to help.

    Just to confirm, were you logged in on the account that has the Woo Memberships licence when you tried to open the ticket and could not see the plugin on the list?

    The reason I’m asking is because the option should only show if you are logged in to the account that has the subscription. If you were, and the option still did not show, please let us know 🙂

    Have a wonderful day!

    Thread Starter David Borrink

    (@davidborrink)

    I was on my own account. I did get a reply from someone using the pre-sales choice and have a conversation going with someone now.

    Plugin Support Zubair Zahid (woo-hc)

    (@doublezed2)

    Hello David Borrink

    Thank you for your reply.

    I understand you were able to contact support via the pre-sales option.
    Please let them know that you have a valid purchase license and you should be able to create a support ticket without the pre-sales option.

    I am sure, Woo ticket support will be able to resolve your issue.
    If you need any help or have any questions, I am here for your assistance. 🙂

    Best regards.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.