Support » Plugin: Orbit Fox by ThemeIsle » Fatal error when running alongside Divi theme

  • Resolved eclev91

    (@eclev91)


    We’ve updated to version 2.10.17 of this plugin and Divi 4.18. PHP 8.0. Never had issues until now. On the front end of the website, we’re seeing the following fatal error:

    [08-Sep-2022 00:11:19 UTC] PHP Fatal error:  Uncaught TypeError: ftp_fget(): Argument #1 ($ftp) must be of type resource, null given in /home/vagrant/code/hsi-duratek/web/wp/wp-admin/includes/class-wp-filesystem-ftpext.php:146
    Stack trace:
    #0 /home/vagrant/code/hsi-duratek/web/wp/wp-admin/includes/class-wp-filesystem-ftpext.php(146): ftp_fget()
    #1 /home/vagrant/code/hsi-duratek/web/app/themes/Divi/includes/builder/feature/dynamic-assets/class-dynamic-assets.php(1144): WP_Filesystem_FTPext->get_contents()
    #2 /home/vagrant/code/hsi-duratek/web/app/themes/Divi/includes/builder/feature/dynamic-assets/class-dynamic-assets.php(1084): ET_Dynamic_Assets->get_assets_data()
    #3 /home/vagrant/code/hsi-duratek/web/app/themes/Divi/includes/builder/feature/dynamic-assets/class-dynamic-assets.php(574): ET_Dynamic_Assets->generate_dynamic_assets()
    #4 /home/vagrant/code/hsi-duratek/web/wp/wp-includes/class-wp-hook.php(307): ET_Dynamic_Assets->initial_setup()
    #5 /home/vagrant/code/hsi-duratek/web/wp/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
    #6 /home/vagrant/code/hsi-duratek/web/wp/wp-includes/plugin.php(524): WP_Hook->do_action()
    #7 /home/vagrant/code/hsi-duratek/web/wp/wp-includes/class-wp.php(787): do_action_ref_array()
    #8 /home/vagrant/code/hsi-duratek/web/wp/wp-includes/functions.php(1330): WP->main()
    #9 /home/vagrant/code/hsi-duratek/web/wp/wp-blog-header.php(16): wp()
    #10 /home/vagrant/code/hsi-duratek/web/index.php(5): require('...')
    #11 {main}
      thrown in /home/vagrant/code/hsi-duratek/web/wp/wp-admin/includes/class-wp-filesystem-ftpext.php on line 146

    In a local environment right now. Tested before we went live. Please let me know if you can/can’t reproduce, and if you can debug to isolate this plugin or Divi as the culprit. Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Poonam Namdev

    (@poonam9)

    Hi @eclev91,

    ​Sorry to hear about the difficulties encountered.

    Would you please rollback the plugin to its previous version and confirm if it resolves the issue? This guide can help >> https://docs.themeisle.com/article/744-how-to-rollback-your-theme-and-plugin

    Also, make sure you are using the latest version of WordPress.

    Let us know how it goes.

    Thread Starter eclev91

    (@eclev91)

    @poonam9 I can confirm that this issue does not happen with Orbit Fox version 2.10.13. So something in 2.10.14 triggered this bug.

    Using latest WP (6.0.2).

    Thread Starter eclev91

    (@eclev91)

    @poonam9 Sorry, I got my versions mixed up. Here’s the full scope of my testing with Divi 4.18, WordPress 6.0.2, and various versions of Orbit Fox –

    2.10.13 – works
    2.10.14 – works
    2.10.15 – fatal error
    2.10.16 – fatal error
    2.10.17 – fatal error

    Thread Starter eclev91

    (@eclev91)

    — ignore this comment, don’t know how to delete it, see previous comment —

    • This reply was modified 2 months, 3 weeks ago by eclev91.
    • This reply was modified 2 months, 3 weeks ago by eclev91.
    • This reply was modified 2 months, 3 weeks ago by eclev91.
    Plugin Support Poonam Namdev

    (@poonam9)

    Hi @eclev91,

    Thank you for the updates.

    I have checked this plugin with PHP version 8, and it’s not giving any errors. Would you please check it with the other theme so we can confirm that it happens only with the Divi theme?

    Thread Starter eclev91

    (@eclev91)

    Per my previous comments, this is specific to Divi.

    Thread Starter eclev91

    (@eclev91)

    Not sure why this specifically breaks Divi, but this is the offending code.

    Plugin Support Poonam Namdev

    (@poonam9)

    Hi @eclev91,

    I have created a fresh test instance with the Divi theme(v4.18.0) and OrbitFox plugin(v2.10.18) using PHP 8. They are working fine together, and there is no error. You can check it here >> https://closedbehavior.s2-tastewp.com/2020/08/05/hello-world/

    I would recommend you contact the Divi theme author so they can check why you are facing this issue. Maybe there is a specific setting or something else that triggered it on your site.

    ​Let us know if we can help with anything else.

    Thread Starter eclev91

    (@eclev91)

    @poonam9 If you reference the GitHub issue I linked, you’ll see the details for how to reproduce. Your team has already addressed my comment and sounds like they’ll be working on a fix. Thanks for your attention.

    Thread Starter eclev91

    (@eclev91)

    Closing in favor of GitHub issue.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.