Support » Plugin: Gantry 4 Framework » Fatal error when run on PHP 7.2

  • Resolved rmmoul

    (@rmmoul)


    I’m getting the following fatal error from this plugin when switching our server over to PHP 7.2

    PHP Fatal error: Uncaught Error: [] operator not supported for strings in /wp-content/themes/rt_gantry_wp/html/gantrymenu/themes/gantry_dropdown/layout.php:77

    I can fix this within the plugin on my end, but it will break with the next plugin update if this isn’t fix on your end. The Gantry 5 plugin PHP 7.2 compatible, and could we just swap over to that plugin without the existing settings breaking or would we have to redo things to get the site to work with version 5?

Viewing 1 replies (of 1 total)
  • Plugin Author Gantry

    (@gantry)

    Gantry 5 is a complete rewrite of Gantry 4 and it’s not backwards compatible. You cannot use Gantry 4 theme in Gantry 5 without rewriting it from scratch.

    Gantry 4 and Gantry 4 default theme are compatible with PHP 7.2. You need to update your Gantry 4 plugin and Gantry 4 default theme from Gantry 4 website

    • This reply was modified 1 year, 10 months ago by Gantry.
Viewing 1 replies (of 1 total)
  • The topic ‘Fatal error when run on PHP 7.2’ is closed to new replies.