Support » Plugin: CRM Salesforce LearnDash Integration » Fatal Error when opening settings

  • Installed and activated plugin ok.

    When I try to go to settings…

    Current plugin: CRM Salesforce LearnDash Integration (version 1.0.1)
    PHP version 7.3.16-1+0~20200320.56+debian9~1.gbp370a75
    
    Error Details
    =============
    An error of type E_ERROR was caused in line 265 of the file /public_html/wp-content/plugins/crm-salesforce-learndash-integration/vendor/twig/twig/src/Extension/CoreExtension.php. Error message: Uncaught Error: Class 'Twig\TwigTest' not found in /public_html/wp-content/plugins/crm-salesforce-learndash-integration/vendor/twig/twig/src/Extension/CoreExtension.php:265
    Stack trace:
    #0 /public_html/wp-content/plugins/crm-salesforce-learndash-integration/vendor/twig/twig/src/ExtensionSet.php(440): Twig\Extension\CoreExtension->getTests()
    #1 /public_html/wp-content/plugins/crm-salesforce-learndash-integration/vendor/twig/twig/src/ExtensionSet.php(420): Twig\ExtensionSet->initExtension(Object(Twig\Extension\CoreExtension))
    #2 /public_html/wp-content/plugins/crm-salesforce-learndash-integration/vendor/twig/twig/src/ExtensionSet.php(394): Twig\ExtensionSet->initExtensions()
    #3 /public_html/wp-content/plugins/crm-salesforce-learndash-integration/vendor/twig/twig/src/Environment.php(972): Twig\ExtensionSet->get
    • This topic was modified 1 year, 7 months ago by deargeek.
Viewing 2 replies - 1 through 2 (of 2 total)
  • We have also the same error!

    Same error with one more precision :

    Uncaught Error: Class 'Twig\TwigTest' not found in /var/www/html/wp-content/plugins/crm-salesforce-learndash-integration/vendor/twig/twig/src/Extension/CoreExtension.php:265

    So I have modified the function on line 265 with “return [];” instead of all the tests that can’t be done because of the unfound function and it passed over it successfully

    I ended up with :

        public function getTests()
        {
            return []; // Added to bypass those tests
            return [
                new TwigTest('even', null, ['node_class' => EvenTest::class]),
                new TwigTest('odd', null, ['node_class' => OddTest::class]),
                new TwigTest('defined', null, ['node_class' => DefinedTest::class]),
                new TwigTest('same as', null, ['node_class' => SameasTest::class]),
                new TwigTest('none', null, ['node_class' => NullTest::class]),
            ...
    

    I suppose a future update will override it but also fix it

    • This reply was modified 1 year, 7 months ago by jpmolla.
    • This reply was modified 1 year, 7 months ago by jpmolla.
    • This reply was modified 1 year, 7 months ago by jpmolla.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Fatal Error when opening settings’ is closed to new replies.