Support » Fixing WordPress » Fatal Error when an Editor but not when Administrator

  • WP noob, so be gentle……

    I’ve just migrated a test site from XAMPP to the server and so far so good…quietly confident and smiling here. But there’s a “but”….

    Browsing the site as a visitor is fine, no issues. Logged in as Administrator is fine, no issues. But when I tested being logged in as Editor I got a variety of

    Fatal error: Allowed memory size of 33554432 bytes exhausted

    …. errors. Some appeared with /wp-includes/cache.php on line 508 and others with wp-includes/class-wp-editor.php on line 606.

    The test site is on a shared server so I can’t play with php.ini but I have tried the .htaccess route and the wp-config.php edit to increase memory

    define(‘WP_MEMORY_LIMIT’, ’64M’);

    . But so far nothing proves successful.

    The config change did allow the Editor role to access the page but the text was invisible (white), no images and nothing worked.

    So two questions really…
    [a] How to fix this and
    [b] How come it’s OK in Administrator mode but not in the lesser role of Editor?

    Fingers crossed 🙂

  • The topic ‘Fatal Error when an Editor but not when Administrator’ is closed to new replies.