Support » Plugin: Health Check & Troubleshooting » fatal error when activating troubleshoot

  • Resolved macardam

    (@macardam)


    I’m using Beaver Builder Theme with a child theme active. When I clicked on troubleshoot, I now only see:

    Warning: require(/home/xxxxxxxxx/public_html/xxxxxxxxx.com/wp-content/themes/bb-theme/inc/template-tags.php): failed to open stream: No such file or directory in /home/xxxxxxxxx/public_html/xxxxxxxxx.com/wp-content/themes/twentysixteen/functions.php on line 375

    Fatal error: require(): Failed opening required ‘/home/xxxxxxxxx/public_html/xxxxxxxxx.com/wp-content/themes/bb-theme/inc/template-tags.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/xxxxxxxxx/public_html/xxxxxxxxx.com/wp-content/themes/twentysixteen/functions.php on line 375

    The dashboard is now completely inaccessible and I only see these errors.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Marius L. J.

    (@clorith)

    Hiya,

    It seems like a theme or plugin that you’ve got active is trying to include some files that are not recognized. You can leave troubleshooting mode by clearing your cookies, or just restarting your computer would do the trick if you are uncertain how to clear out cookies.

    We’ve got an active ticket to improve detection and prevention of scenarios like this in an upcoming version of the plugin, sorry for the inconvenience!

    So essentially, the plug-in is unusable for my setup at this time?

    Plugin Author Marius L. J.

    (@clorith)

    Unfortunately, it would appear that way.

    Is that child theme open sourced anywhere so that I can do some tests against it?

    We’re using a premium theme so have to pay for the theme: https://www.wpbeaverbuilder.com/wordpress-framework-theme/

    I think Beaver one of the most widely used builders and theme.

    I believe your assessment is incorrect…

    I have a different theme (https://themeforest.net/item/savoy-minimalist-ajax-woocommerce-theme/12537825) and clicking “Troubleshoot” throws an error message regarding Line 592 of the Twenty Seventeen theme’s functions.php:
    require get_parent_theme_file_path( '/inc/custom-header.php' );
    It’s trying to load this file, which does exist in Twenty Seventeen, but from the Savoy theme’s location because of get_parent_theme_file_path()

    So it’s sort of an issue with your plugin + Twenty Seventeen as far as I can tell.

    P.S. Thanks for your great plugin!

    Same probleme here ! Help plz

    How to disable the troubleshoting mode without and back office acces ????

    Plugin Author Marius L. J.

    (@clorith)

    Good catch @cliffpaulick!

    I’ll look into why it’s behaving that way, it’s an odd behavior but seems related to the child theme processing.

    You bet. I didn’t dig any deeper than this, but if you can’t figure it out let me know and I can try harder for you 😉

    Plugin Author Marius L. J.

    (@clorith)

    If you want to dig into it, you are more than welcome to do so, all our development happens on GitHub (https://github.com/wordpress/health-check) and encourages community participation so long as they want to 🙂

    If not, I’ll be looking at it over the weekend as well.

    Just to give an update here – This error does seem related to child themes. I changed my site so the parent theme was active, instead of the child theme, and the plug-in worked fine.

    Plugin Author Marius L. J.

    (@clorith)

    Good news everyone!

    We’ve tracked down the root cause for this happening, and have patched it up on the development version of the plugin. The fix will be included in the next release (version 1.2.0) which is scheduled about a week from now.

    Thank you so much for the input here, it saved a lot of time narrowing down the reason for the errors!

    I’m going to mark the topic as resolved, just so I can keep track of what still needs investigating, although the fix won’t officially be available for another week.
    If anyone wants a sneak peek at the upcoming changes, and the version that (should) be patched for this, you can grab a copy at https://github.com/WordPress/health-check/releases/download/1.2.0-beta1/health-check.zip

    Not that we’re still doing some more extensive tests on the fix, so no guarantees until the final version is released, but preliminary testing is looking promising 🙂

    Great! Will try when the update is released and let you know if it works.

    Moderator Bet Hannon

    (@bethannon1)

    Support Team Volunteer Coordinator

    I tried the github dev version, and it worked on the site that had issues with Health Check last week. Good work!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘fatal error when activating troubleshoot’ is closed to new replies.